I'm guessing this is some sort of Bluetooth keyboard recognition and/or selection/activation issue in Android that I can't seem to figure out.

The iCade Arcade Bluetooth device is in essence a keyboard device. I can pair it with a Nexus 10 tablet, and after I do, I can see various characters appear in a text app when I move the joystick around and press the buttons.

But my Android phone is being stubborn. It pairs ok, but the input refuses to get fed to the apps. I also have an actual Bluetooth keyboard, and it works ok with that phone.

I've tried various Bluetooth connect apps, and there I can see a list of paired devices and the option to "connect" to a device. It refuses to work.

What am I missing here?

Does anyone know of a Bluetooth helper app of sorts that also gives immediate feedback on what it is picking up from the selected Bluetooth device? Is there anything specific I could look for in logcat?

The phone is Android 4.4 and I can't upgrade it (Chinese phone with no firmware support). It's an ECOO S04 Aurora Plus 3GB. The Nexus 10 I think runs on Android Lollipop.

1 Answer 1


I don't think your Nexus would be Android Lollipop. Android Lollipop is version 5.0, and the iCade Arcade only connects with Android 4.2 or below to a certain minimal version. Starting from Android 4.3, the iCade no longer functions properly as you are then required to input a Bluetooth PIN with 6 digits, rather than 4, which is the number of digits that an iCade connects with when using an iPad, iPod, or iPhone.

Though if you are able to check your version of Android on your Nexus, and it is indeed Android 5.0, I would like to know how you managed to connect it with the iCade, which is something I am trying to figure out myself.

  • I upgraded the Nexus 10 at one point. It's possible that when I tried it with the Nexus, that this was before I upgraded. The Nexus 10 has since died. The flash rom appears to be non-writable, but that's another matter (also on SO). I now also have a Xiaomi Mi Max which is Android 6 based. I was able to pair it (the phone claims it paired), and that was after entering the 6 digits, plus enter. But this phone also, doesn't show any keys pressed when interacting with the icade. Strange how it paired, yet no further input is shown from it...
    – Mike
    Dec 18, 2016 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .