0

I recently purchased a Samsung S7 Edge. As I like to play around with my phones a lot, one of the first things I did was root it. Not thinking properly, after enabling 'OEM Unlock' and rooting my phone, I decided to turn off 'OEM Unlock' (I figured this would be correct as on my old Nexus 7 I unlocked the bootloader, rooted & flashed it with a custom ROM and re-locked it no issues) but I didn't google anything to confirm this wouldn't cause issues. After rebooting, I realised my mistake: My phone would refuse to restart due to the FRP lock. Because of this, I flashed a new stock ROM from Sammmobile to fix this - from what I can tell this is a trusted website as everything linked back to there. This is where issues have started to occur: since flashing the stock ROM back, now when I unlock my phone for the first time a series of applications report they have crashed, notably:

LoggingService

Message Service

As well as occasionally:

Photos

Google Play Games

The issue I am now facing is that when I open the stock 'Messages' application, it crashes. Attempting to open it through settings to access the application settings, it crashes. I have since downloaded Google's 'Messenger' application and tried to use it, still no luck. I used Facebook's 'Messenger' application with integrated SMS, this just caused the recent messages screen to show 'An error occurred, please try again', however upon disabling SMS option I can see all my facebook messages.

So tl;dr:

  • I cannot receive (or view - not sure. No notification was shown when an SMS was expected) text messages.

  • Third party applications cannot view text messages in place of the default application.

  • Message Service system application crashes when device starts

The following fixes have been tried:

  • Clearing 'Messages' data and cache
  • Clearing 'Message Service' cache
  • Restarting the device (obviously)

Is anyone able to suggest other fixes to help solve my issue?

Thanks in advance

0

The issue was fixed. By running an adb logcat connection (adb logcat -f "storage/emulated/0/Logcat.txt") with my phone attached to my computer, I was able to log the output from the console when the application crashed. To produce the errors, I ran the Messages application. The output from the application can be found here. To solve the issue, I navigated to the mmssms.db file (look here for how to find it) and renamed the file to mmssms_old.db, essentially deleting it. I then rebooted the device and ran the application - it worked! Bear in mind all messages will be deleted, which is why I only renamed the database not deleted it entirely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.