1

I'm currently using Android 4.0.4 (Ice Cream Sandwich) on an old Qualcomm, ARMv7 device, with a 2GB SD card.

I want to bootstrap Debian Wheezy onto the SD card, but FAT32 can't handle symlinks and attributes, so I need to format the card as an ext filesystem. My computer does not have microSD slots, so I'll need to unmount the sdcard and then use some tool to format it from Android.

The problem is that I don't have any "unmount" options in the settings. I tried to root the phone and use ADB to run umount, but it fails on "Device or resource busy".

The phone isn't currently rooted, but I can easily do it in a few moments if needed.

I have a USB cable and ADB installed on my PC.

My PC has Gentoo Linux installed, and I have Debian Jessie available if needed.

I'm OK with using the command line.

May some Android comrade help me?

  • 1
    I ran into a similar problem in 4.4; it turned out that having the cable plugged in was what prevented the unmount. – Darwin von Corax Jun 29 '16 at 0:05
1

Turns out there was much more to unmount beyond /mnt/sdcard. Through ADB (and rooted) I unmounted /mnt/sdcard/.android_secure, then /mnt/sdcard, then everything under /mnt. Then I was able to partition my SD card.

I hope someone can make good use of this thread one day!

  • Are you sure that you unmounted the real external SD? Usually, the name /sdcard or /storage/sdcard0 means internal storage, whilst the external is /storage/sdcard1, /mnt/external_sd, /external_sd or /mnt/media_rw/sdcard1. – Death Mask Salesman Jun 29 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.