1

Not able to flash android N preview system.img in Nexus 6P

Android N preview (Nexus 6P "angler")

Build : angler-npd56n-factory-1ce5ccad.tgz

  1. fastboot flash bootloader bootloader-angler-angler--03.55.img
  2. fastboot reboot-bootloader
  3. fastboot flash radio radio-angler-angler-03.67.img
  4. fastboot reboot-bootloader
  5. fastboot erase system
  6. fastboot erase boot
  7. fastboot erase recovery
  8. fastboot erase cache

  9. fastboot flash system system.img

    • error: cannot load 'system.img'
  10. fastboot flash boot boot.img

  11. fastboot flash recovery recovery.img
  12. fastboot flash cache cache.img
  13. fastboot flash vendor vendor.img
  14. fastboot reboot

Already tried below options

  • fastboot -S 512M flash system system.img

  • fastboot -S 1024M flash system system.img

  • fastboot -S 2048M flash system system.img

  • Sounds like something is wrong with the system.img file. Could the download have been corrupted? – Dan Hulme Jun 29 '16 at 8:32
  • same commands working for build : 6.0.1 (MTC19V) from developers.google.com/android/nexus/images#sojus – elinus Jun 29 '16 at 9:02
  • It's probably not the command. Bet it's something that's to do with the system.img itself. Did you do a md5 checksum verification on what's available on the download page vs what you have? – blueren Jun 29 '16 at 9:41
  • Verified checksum, it is still not working. – elinus Jun 30 '16 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.