This story of images occasionally pops up on opening new links in Chrome. These links are for legitimate websites such as imgur and reddit. When it happens, I'm on mobile data. When I choose the tab, and click the link again, no pop-up appears.

Here's the relevant portion from chrome://version

Google Chrome 51.0.2704.81 (Official Build) (32-bit)


OS Android 6.0.1; E5823 Build/32.2.A.0.224

This is a screenshot of the pop-up:

garbage virus warning

How do I find out what caused this, and how do I fix it?

It happened again, this time without clicking a link. I was in reddit, it just popped up.

URL: http://rcknmwcyct.pw/gaz6s9/x1psi.html?model=Xperia%20Z5%20Compact&brand=Sony&ip=

Here's the pages without the pop-up:

virus page

When I try to click back, I get to this page:

broken link to Android market

Which is something about appflood security. I haven't managed to teach it down to anything though.

  • 1
    You don't fix it. You ignore it. That's pure click-bait. You'll certainly have a bad situation afterward, that's true. That may be the only thing that's true, except your device brand. The message is delivered to sound highly specific and demanding. <Esc> or back out of it without clicking OK. Use RecentApps to force-close the browser session if you have to. Ignore them always.
    – wbogacz
    Commented Jun 30, 2016 at 19:32
  • 1
    Clear Chrome's cache and data from the app settings in the system settings app. Start there.
    – Ethan Z
    Commented Jun 30, 2016 at 19:44
  • Even after your edit, it still sounds more like the site with the link is making its link look like a reputable site but the link is really to this scam website.
    – Dan Hulme
    Commented Jul 1, 2016 at 8:25
  • 1
    Have you tried uninstalling chrome, and installing it again?
    – cavpollo
    Commented Jul 2, 2016 at 5:20

1 Answer 1


I'm assuming this only happens in chrome and not any other browser or device. If it does happen on another device then the problem would be that a virus hijacked your router(on WiFi) and changed the DNS settings. Solution logon to your router and change the DNS settings to be automatically picked from your ISP.

You could

  1. Head to settings and disable Javascript. Which disables the redirect link from functioning as long as Javascript is off but is quite hectic since genuine websites will most likely require Javascript to function.
  2. Check your DNS settings and ensure that it's either set to automatically pick DNS settings from ISP or on a DNS server you know of such as googles DNS servers( and
  3. Root your phone and install Ad Blocker This would prevent the popup links from generating.
  • I was on data at the time, so not my router. By Java do you mean JavaScript? Commented Jun 30, 2016 at 22:12
  • 1
    Java is something else then JavaScript. You should edit your answer.
    – Thomas Vos
    Commented Jul 1, 2016 at 5:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .