5

There's an Asus 240 MIMO Wifi access point. There's a laptop running Windows XP that uses that access point no problem for years so far. And there's an Android based HTC Desire S smartphone that has problems. The objective is to make the smartphone access the Internet via the Wifi access point.

I open "wireless networks" configuration pane, "enable" Wifi - it goes through "scanning" and "obtaining IP address" stages, says "connected to TheRightNetworkName". The Wifi symbol is displayed in the bar under the top of the screen. Yet when I try to open any page in a browser if wouldn't do so and claim there were problems accessing that page.

I tried the following (listed in this answer below, thanks to user Matthew Read):

  • rebooted the phone - doesn't help
  • checked MAC filtering on the AP - it is disabled
  • disabled the firewall on the AP - doesn't help
  • tried to change channels - doesn't help, the AP has 13 channels if that matters
  • tried to change to 2.4 GHz - looks like it is already the only option, couldn't find any way to change the range
  • didn't try to switch from WPA that is currently used to WEP because it feels quite scary - I can mess things up
  • tried switching modes - b, g, b/g - doesn't help

How do I debug and resolve this issue?

2
  • What kind of security is on the network? WEP? WPA? It almost sounds like the network is using Mac address filtering. Commented Oct 25, 2011 at 14:16
  • @PortableWorld: WPA is used, no MAC filtering, I updated the question to include my findings.
    – sharptooth
    Commented Oct 26, 2011 at 7:23

3 Answers 3

2

Make sure that you are using DHCP on your phone; if you have a static DNS set and it's the wrong one, you won't be able to browse the web. Go to Settings->Wireless And Network->Wi-Fi settings, hit the context button (or right click button, or whatever you call it), select Advanced, and make sure Use Static IP is unchecked.

3
  • DHCP is used - checked that already.
    – sharptooth
    Commented Nov 28, 2011 at 6:05
  • As a complete shot in the dark, have you tried using a browser other than stock and seeing if that works?
    – Logos
    Commented Nov 28, 2011 at 13:45
  • Yes, I tried Firefox - results are the same.
    – sharptooth
    Commented Nov 29, 2011 at 6:03
1

Assuming that the smartphone connects to the AP as you say, try the following.

  • Take the IP of the phone.
  • Connect to the same AP your laptop
  • Run ping ip_of_phone from cmd (if you are using win) or from Terminal
  • If you can do a ping means that something is wrong, perhaps with the DNS
  • If you can not ping, probably something is wrong with IP assignment. Perhaps a two devices have the same IP. A common mistake is that people assign an IP to an AP and do not exlude that IP from the DHCP pool of the router.
2
  • I tried that - ping succeeds. What else can I check?
    – sharptooth
    Commented Nov 1, 2011 at 7:56
  • Can you try using staic IP (whatever IP you are getting for the phone) and in DNS use 4.2.2.2 and 8.8.8.8
    – roxan
    Commented Dec 26, 2011 at 4:09
0

First ensure the phone is using the right password for the network and try rebooting the phone.

Then play with with your AP, one of these at a time:

  • Reboot it
  • Ensure MAC filtering isn't on
  • Try disabling any firewall it might have
  • Ensure it uses channel 1 or 6 or 11 (assuming you're in an 11-channel region)
  • Try switching to 2.4 GHz if it's broadcasting on the 5.0 GHz band
  • Try switching from WPA to WEP encryption or vice-versa
  • Try switching to or from mixed mode (e.g. 802.11 b/g rather than just 802.11b, etc.)

If nothing changes, please provide your phone model and I'll try to help further.

3
  • I checked everything except switching to WEP - that feels very risky. I updated the question to include my findings and phone and AP model.
    – sharptooth
    Commented Oct 26, 2011 at 7:24
  • @sharptooth Fair enough. Does the phone work OK on other Wi-Fi networks? Commented Oct 26, 2011 at 12:36
  • Yes, it works on another WPA-protected network okay.
    – sharptooth
    Commented Oct 26, 2011 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .