2

I have a 'Rooted Samsung Galaxy Note 10.1 NT-N8000'(tablet) running Unofficial CM 13 Marshmallow 6.0.1 and a TWRP touch recovery. After i flashed cm13 i had no keyboard anymore, so i couldnt login to wifi and login to the google play store... Then i made a free wifi hotspot on my phone and logged in (so i had wifi) so i could use the microphone to search for an app but i needed to login the playstore, i also cant downlaod the app to my tablet from the pc cuz i havent logged in with my google account on my tablet yet. Then i downloaded a keyboard app on my phone, extract it, email it to my computer, on my computer transfer it to an sdcard, and then plugged it in my tablet and installed it... (Pfffff) but it still doesnt work! i tried google keyboard and Chrooma keyboard. NONE work, and the settings are all fine ! Thank you soo much for the help guys!!!

Please help! - Julian

  • Download keyboard application from third-party websites. Put it in SD card and install. Must work. – MANI Jul 1 '16 at 16:03
  • I remember there are issues with the AOSP keyboard on some CM13 builds (see e.g. this thread). Did you already install GApps and, if so, did you use OpenGApps for that? Then it might be related. – Izzy Jul 1 '16 at 16:15
  • Ok, i installed swiftkey and the keyboard sorta popped up, the keyboard itself didnt but the suggestionbar did so thats kinda strange... any help ? – Julian Jul 2 '16 at 17:56
  • Yes i used OpenGapps for ARM, android 6 and the pico package (first i used the stock/full but i got alot of crashes so i formatted everything including cache and dalvik and flashed pico) – Julian Jul 2 '16 at 17:58
2

I had the same issue. Just go to the right, choose language, and then you slide "Hardware show input method" to On. Should work.

1

CyanogenMod has a keyboard built in, did you try going to Settings -> Language & Input and make sure you have a keyboard set as "Current Keyboard", the default keyboard in CM is Android Keyboard (AOSP)?

If there is truly no keyboard installed, you can go to http://www.apkmirror.com/ and download any number of keyboards, such as Swiftkey Keyboard or Google Keyboard as examples, then install them manually. You may need to make sure that Unknown Sources is enabled in Settings -> Security

  • i tried to do that but i still have no keyboard and i cant download a keyboard cuz i dont have a keyboard to search or type that in – Julian Jul 1 '16 at 15:12
  • @Julian Is the keyboard listed in Settings->Language&Inputs? – acejavelin Jul 1 '16 at 15:13
  • 1
    @Julian sure you can. Just visit Playstore with a web browser from some other machine, login with your Google account, find some keyboard, and push the "install" button. As long as your device has any network connection (mobile or WiFi), you should see the install starting within seconds. – Izzy Jul 1 '16 at 16:04
  • @Izzy Also if i havent logged in to my google account on my tablet yet ? – Julian Jul 2 '16 at 11:05
  • @acejavalin yes its listed in language&inputs – Julian Jul 2 '16 at 11:08
0

I had problems with keyboard on CM13 because of gapps you should delete this file "/system/lib/libjni_latinimegoogle.so" right after flashing ROM and the GAPPS. You can delete it from TWRP's file manager, if you have troubles with deleting or finding file let me know.

0

if you are installing any custom rom than go for the stock gapps rather than pico or nano stock gapps cover all the google services including keyboard i had the same issue when i have installed ressurection remix with gapps pico but after installing stock gapps the issue was solved ....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.