3

I have a 'Rooted Samsung Galaxy Note 10.1 NT-N8000'(tablet) running Unofficial CM 13 Marshmallow 6.0.1 and a TWRP touch recovery. After I flashed CM13, I had no keyboard anymore, so I couldn't log in to WiFi and Google Play Store.

Then I made a free WiFi hotspot on my phone and logged in (so I had WiFi) so I could use the microphone to search for an app, but I needed to log in to the Play Store. I also can't download the app to my tablet from the PC because I haven't logged in with my Google account on my tablet yet.

Then I downloaded a keyboard app on my phone, extract it, email it to my computer, on my computer transferred it to an SD card, and then plugged it into my tablet and installed it, but it still doesn't work. I tried Google Keyboard and Chrooma keyboard but none work, and the settings are all fine.

How to fix this?

4
  • Download keyboard application from third-party websites. Put it in SD card and install. Must work. Jul 1, 2016 at 16:03
  • I remember there are issues with the AOSP keyboard on some CM13 builds (see e.g. this thread). Did you already install GApps and, if so, did you use OpenGApps for that? Then it might be related.
    – Izzy
    Jul 1, 2016 at 16:15
  • Ok, i installed swiftkey and the keyboard sorta popped up, the keyboard itself didnt but the suggestionbar did so thats kinda strange... any help ?
    – Julian
    Jul 2, 2016 at 17:56
  • Yes i used OpenGapps for ARM, android 6 and the pico package (first i used the stock/full but i got alot of crashes so i formatted everything including cache and dalvik and flashed pico)
    – Julian
    Jul 2, 2016 at 17:58

5 Answers 5

3

I had the same issue. Just go to the right, choose language, and then you slide "Hardware show input method" to On. Should work.

1

CyanogenMod has a keyboard built in, did you try going to Settings -> Language & Input and make sure you have a keyboard set as "Current Keyboard", the default keyboard in CM is Android Keyboard (AOSP)?

If there is truly no keyboard installed, you can go to http://www.apkmirror.com/ and download any number of keyboards, such as Swiftkey Keyboard or Google Keyboard as examples, then install them manually. You may need to make sure that Unknown Sources is enabled in Settings -> Security

6
  • i tried to do that but i still have no keyboard and i cant download a keyboard cuz i dont have a keyboard to search or type that in
    – Julian
    Jul 1, 2016 at 15:12
  • @Julian Is the keyboard listed in Settings->Language&Inputs?
    – acejavelin
    Jul 1, 2016 at 15:13
  • 1
    @Julian sure you can. Just visit Playstore with a web browser from some other machine, login with your Google account, find some keyboard, and push the "install" button. As long as your device has any network connection (mobile or WiFi), you should see the install starting within seconds.
    – Izzy
    Jul 1, 2016 at 16:04
  • @Izzy Also if i havent logged in to my google account on my tablet yet ?
    – Julian
    Jul 2, 2016 at 11:05
  • @acejavalin yes its listed in language&inputs
    – Julian
    Jul 2, 2016 at 11:08
1

I solved this problem. I think it occurs because there is a default physical keyboard configured called "sec_keyboard". The OS thinks this is available, so it doesn't choose to make the virtual keyboard appear - and I can't see how to remove it. Fortunately, if you click on the settings for "Physical keyboard" one of them is "Show virtual keyboard" under "Keyboard assistance". Enable this. The OS then puts up the virtual keyboard (whether the original AOSP or Gboard or something else) on the screen when keyboard input is needed, and you can then type on it! It's a bit of a kludge, but it does seem to deliver the desired result by a devious method. I trust there is a better way (probably using a different gapps installation), but this is a simpler solution once you have done this installation with the suggested files.

0

I had problems with the keyboard on CM13 because of Gapps. You should delete this file /system/lib/libjni_latinimegoogle.so right after flashing ROM and the Gapps. You can delete it from TWRP's file manager.

0

if you are installing any custom ROM, then go for the Stock Gapps rather than Pico or Nano. Stock Gapps cover all the Google services including the keyboard. I had the same issue when I have installed Resurrection Remix with Gapps Pico, but after installing Stock Gapps the issue was solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .