1

It started when I factory reset with twrp and flashed a new ROM. I tried different ROMs and stock when I noticed that I couldn't turn wifi.

I ran ifconfig with the terminal emulator app and found out I was missing wlan0. Running "adb shell ifconfig wlan0" gave "ifconfig: wlan0: No such device." I was looking at the logcat live while tapping to turn on wifi and it was giving me "Supplicant not running, cannot connect" and the drivers weren't able to be initialized. Going through the phone and entering in ##4636## for the wifi information, wifi state was stuck on enabling and the supplicant state is uninitialized. The MAC address was 02:00:00:00:00:00 if that is of any importance. After searching some more for help, I found out /sys/devices/virtual/net/ was missing wlan0 as well. I think that the wlan0 firmware or drivers are missing, but I'm not sure. I tried "fixing" the permissions on the supplicant file and renaming the file, but to no avail. I would like some help on this. Thanks

Note 4 (N910T variant) The ROMs I tried TekHD ROM (5.1.1) CMRemix 13 (6.0.1) Resurrection Remix 5.6.9 (6.0.1) Stock (6.0.1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.