After 7 months LG Nexus 5X now doesn't show "Charging rapidly" but only "Charging".

Ampere app shows 1700 - 2100 mA max. Overall charging time now 50% longer than initially was.

In accordance to screenshots of Ampere I see the following wattage:

4.07V * 0.89A = 3.62W


4.26V * 1.79A = 7.62W

Both measurements are far from 15W declared by Nexus 5X specs.

I have checked my original 5X charger with Nexus 6P phone - it displays "Charging rapidly" on 6P from my charger. This makes me to believe the issue with the phone or its battery or QC IC (Quick Charge integrated circuit).


  • My charger is OK with Nexus 6P -> "Charging rapidly"
  • Nexus 6P charger doesn't detected on my 5X at all -> no charge, nothing
  • Switching cables on 6P charger with 6P phone -> 5X cable OK on 6P "Charging rapidly"

Conclusion: Phone Nexus 5X itself is suspected: battery or charger chip or system.

  • Somewhat related: Android phone “charging slowly”: How to make it faster
    – Andrew T.
    Jul 5, 2016 at 1:03
  • My question exactly about the issue with the stock (original) charger from LG and original cable for Nexus 5X. I did not play with any third party cables and chargers. Jul 5, 2016 at 10:00
  • 1
    As Andrew clarified in his answer , it is the wattage that counts not just the current as measured by Ampere app (which appears to be fine). You would need to measure the voltage also to see if the wattage (product of voltage and Ampere ) is fine.
    – beeshyams
    Jul 5, 2016 at 11:29
  • In accordance to screenshots of Ampere I see the following wattage: goo.gl/photos/EJSwT76mD3dmVDU9A 4.07V * 0.89A = 3.62W or 4.26V * 1.79A = 7.62 Both are far from 15W declared by Nexus 5X spec. Jul 5, 2016 at 15:08
  • 1
    So that means it could be a problem with charger and cable combo. One way to confirm this would be to try another original set if you can lay your hands on it or with different chargers. Alternatively, now that you know that wattage could be the issue take to service centre, device still being in warranty and post the outcome as a solution if it is solved, else edit question with inputs
    – beeshyams
    Jul 6, 2016 at 8:20

1 Answer 1


I had the same issue with my Nexus 6P. Tried everything but nothing worked. Visited service centre and got it fixed. They told some hardware issues with the fast charging chip.

I read somewhere that flashing the firmware again using Fastboot on the phone solves this issue for some users.I didn't worked for me. Might you wanna try. Good Luck!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .