1

I try to get internet on my phone from my computer without instlling any tools.

My configuration looks like :

mybox -----(Ethernet)------[my computer]------(USB)-----[the phone]

I enabled usb tethering so I have two interface on my computer : eth0 and usb0.

I read How to set up reverse tethering over USB? and I have done :

One the computer:

sudo ifconfig eth0 0.0.0.0  
sudo ifconfig usb0 0.0.0.0  
sudo brctl addbr br0  
sudo brctl addif br0 eth0  
sudo brctl addif br0 usb0  
sudo ifconfig br0 up  
sudo dhclient br0

On the phone :

su
netcfg rndis0 dhcp

After that I have :

IP of rndis0 on the phone : 192.168.1.22/24
IP of br0(eth0 + usb0) on my computer : 192.168.1.21/24
IP of the box : 192.168.1.1/24

When I try to do a ping on the computer and on the smartphone, it works :

ping 8.8.8.8

But if I try to ping on a domain it work on the computer but not on the phone:

root@hammerhead:/ # ping google.fr
ping: unknown host google.fr

Ok so maybe a dns problem of the smarphone? (I don't believe on it because it is obtain by dhcp and the ping work on the computer):

root@hammerhead:/ # getprop | grep dns  
[dhcp.wlan0.dns1]: [192.168.1.1]
[dhcp.wlan0.dns2]: []
[dhcp.wlan0.dns3]: []
[dhcp.wlan0.dns4]: []
[net.change]: [net.rndis0.dns2]
[net.dns1]: [212.27.40.240]
[net.dns2]: [212.27.40.241]
[net.rmnet0.dns1]: []
[net.rmnet0.dns2]: []
[net.rndis0.dns1]: [192.168.1.1]
[net.rndis0.dns2]: []
root@hammerhead:/ # ping google.fr

Also, some applications (youtube, chrome) say I'm offline.

Then my questions are : why these applications say I'm offline when I can do ping 8.8.8.8 or another addresses? and why the ping of a domain doesn't work?

Of course, I can give you more informations if you want

EDIT (new information) Also when i delete all rules except unreachable :

root@hammerhead:/ # ip rule show
32000:  from all unreachable

and if I try ping 8.8.8.8 it give me connect: Network is unreachable which is normal. but when i try ping google.com I get ping: unknown host google.com. So a ping to a domain just doesn't reach the 'routing stage'. I can have the same behaviour on a linux machine where /etc/resolv.conf is empty but on my android I get the DNS from the dhcp server of my box. When i connect my phone to my box with wifi it work fine with dhcp...

Thank you

  • just an additionnal remark : when i do ping google.com there is nothing on usb0 (unlike to ping 8.8.8.8) So it seems there is something blockink my ping when it is a domain... – sebastien dontneedtoknowthat Jul 6 '16 at 7:06
  • I solved the dns problem by using ndc. but know I can browse any website with chrome application but youtube application still tells me I have no connection. I don't know why – sebastien dontneedtoknowthat Jul 9 '16 at 13:58
  • Can you tell how you solved the dns problem using ndc? – FirstOne Aug 13 '16 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.