1

I Wants to know that how the android os is communicating with the storage devices, as because I have two USB Devices from same vendor (ScanDisk) and of equal size (8 GB) and having same File System (FAT32).

Scenario is, I am trying to use those USB Devices using OTG Cable With my MOTO X Play. Lets say USB-A is working fine but not USB-B. Even i Tried to format them using Windows OS to NTFS / FAT32, but still the result is same.

In next attempt I made copy of default folder / directory that usually created by android system to external storage to both USB's, then the Scenario get reversed. with FAT32 / NTFS USB-B works fine but not USB-A.

Surprised? I'm too but I wants to find the reason. Both USB are working fine with other OS like Windows / Linux(Desktop version) as I checked already.

  • Do you realise that NTFS and FAT32 are not the same thing? With that in mind, could you edit your question and make it clear exactly what filesystem you've used on the two USB sticks. – Dan Hulme Jul 6 '16 at 6:19
  • I tried with bote file system. First i tried with FAT32 and in next attempt i tried with NTFS that's what I want to say. – iSandeep Jul 6 '16 at 6:22
  • So are you saying it worked with FAT32 but not with NTFS? – Dan Hulme Jul 6 '16 at 6:24
  • I tried with bith file system first the observed USB-B is not working and in next try i copied default folders of Android os those are usually gets created to storage location to the both USB's then the scenario gets reverse means USB-B worked fine. – iSandeep Jul 6 '16 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.