Im running Ubuntu 16.04

adb version
Android Debug Bridge version 1.0.32

However, when I plug in my devices for testing via ADB I always get an unauthorized error.

adb devices

List of devices attached 
LGD855a1098057  unauthorized

adb works flawlessly on Windows 7 x64 SP1with Koushik Douttas Universal ADB driver and my friends Macbook , this singles out the Ubuntu 16.04 as the problem.

Things I have tried:

  • I tried revoking previous USB authorizations.

Nothing happened.

  • Switching adb debugging on and off.

However, the CLI just keeps mocking me with the unauthorized error.

  • Switching ports.

Each port on my 16 port development rig has been tried.

  • Updating adb.

    android-tools-adb is already the newest version (5.1.1r36+git20160322-0ubuntu3). android-tools-fastboot is already the newest version (5.1.1r36+git20160322-0ubuntu3).


Same problem here with exact same linux ubuntu version.

The solution for me that work well is

1 - adb kill-server

2 - sudo adb usb

after this you mobile will ask for authorization and work well. so, adb needs root privilege.


Kill the adb server if running:

adb kill-server

Remove ~/.android directory with all its content:

 rm -rf ~/.android

Don't forget to Revoke USB debugging authorizations in developer options in your android device.

Start the adb server:

 adb start-server

Search for devices:

adb devices

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.