This seemed to just start happening recently but for some reason Google Maps can't get my location (just have a gray dot). If I go into Settings -> Location and choose High accuracy or Device only then I will just get the gray dot. If I change it to Battery saving I can get the blue dot but it's obviously not as accurate so I'd like it to use GPS. At first I thought there was a problem with GPS with my phone so I downloaded a couple of GPS status apps and they were all able to get GPS signal immediately (even with poor conditions; e.g., indoors). If I go to maps.google.com in my browser on my phone (either Chrome or Firefox) I get a blue dot. I've also downloaded Waze and HERE Maps and they can get my location without problem.

In Google Maps app I can tap on the gray dot and I get a message saying it can't connect to Maps and I should try again in a few minutes. There is also an option to report blue dot issues. This has been happening for a couple weeks now and it's really frustrating as I use Google Maps all the time.

I was thinking that maybe there was some issue with Google Maps and Google Play services but I double checked and I have the latest versions of both (I'm on a stock non-rooted Nexus 5x). Is it possible there is a bug in Google Maps that I seem to be the only one experiencing? Any help narrowing this down would be greatly appreciated.

  • How long are you waiting for the location fix with the settings high accuracy or device only? If your other applications are using GPS only and getting a fix immediately indoors, this is probably not a new location fix, but a stored value.
    – mattm
    Commented Jul 6, 2016 at 12:52
  • I've waited quite a while. At one point even let it sit for 30 minutes. The other applications indicate they have live connections with multiple GPS satellites.
    – JeffJones
    Commented Jul 6, 2016 at 14:42
  • Exactly the same behavior, I detected this problem on my phone just yesterday. Several months ago I used Google Maps regularly with no problems. Maybe it has broken with some installed update.
    – peter
    Commented Jul 6, 2016 at 16:43
  • Try installing GPS Status & Toolbox from the play store, no special permissions, it will tell you if your GPS is functioning correctly. play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2
    – acejavelin
    Commented Jul 6, 2016 at 17:25
  • @acejavelin -- That's one of the GPS apps that I tried. It shows GPS working just fine. It seems to be an issue specific to Google Maps.
    – JeffJones
    Commented Jul 6, 2016 at 22:19

2 Answers 2


I had the same problem; fixing it was as simple as enabling automatic date and time and automatic time zone. Not sure what program turned those off but correcting that make the problem go away. (When I turn them off, the problem re-occurs.)

  • 1
    I was sure this was already enabled so I almost dismissed your answer. But I double checked anyways and sure enough it wasn't enabled (like you, I have no idea why it was turned off). Turning it on fixed it! You may want to add a comment to that Google forum post that talks about this issue. That might assist people there and hopefully get Google's attention to fix this (this is clearly a bug in Google Maps and/or Play Services).
    – JeffJones
    Commented Aug 19, 2016 at 12:06

Date and time. ....

Go to your device settings, Date and time. Check the automatic setting is on. If your device doesn't have auto setting for date and time, ensure your time is as accurate as possible. Should pop the blue dot up.

The Satellite connections seem to use this to assist your gps location. Without it, your position cannot be calculated and this will hamper route finding.

A recent update may have thrown this automatic date and time setting off. Curse 'em!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .