2

I recently got a Samsung Galaxy S7 Edge, and was using it just fine. I imported all of my previous apps and app data and everything went smoothly.

Then, a few weeks later, I tried to record a video, and received the popup:

Warning: Recording Failed

This only happened with the video, and NOT with regular pictures (I could capture still images)

I've tried:

  1. Taking out the microSD card
  2. Formatting the SD card
  3. Restarting the device
  4. Clearing camera cache and data
  5. Clearing system-wide cache partition
  6. Factory data reset

Option 6) actually solved it, so I think it may be the cause of an app. What's going on?

6 Answers 6

1

The culprit is probably an app that accidentally doesn't release a critical lock.

In my case, it was the Cortana app that was causing the issue. It has a setting for the "Hey Cortana" hotword in the app, which requires that the application grab the microphone lock. It seems like the app, when quit, never released the lock, and so the camera couldn't have access to the microphone (and couldn't record)

If you don't have Cortana, try scouring your app list for apps that will obtain a lock for (and have the possibility of keeping it across runs):

  1. Microphone
  2. Camera
  3. Storage

P.S. I've also heard that this issue can be caused by interference from Smart Stay, but I've never had issues with it

1

this is because some app is locking your mic or camera. For example, if you have the Hue Disco app (which uses the mic to measure the music so that the Philips Hue lights can change) and then you try to load the Camera app to record a video, it will fail to record the video because the Hue Disco app is already using the mic. You can't have 2 apps using the same microphone at the same time.

0

On my galaxy S8+, I had to set options to High Performance for the video recording to work

1
  • Where did you find this option? This answer could be helpful but right now it's not quite enough to help. Could you edit it to describe further?
    – Dan Hulme
    Jul 4, 2017 at 9:07
0

This issue started happening to me after the June 2018 update. I'd restart the phone and for about a min, the video recording would work fine. Then suddenly stopped working. I have a microphone blocker app. I disabled that and recording started working again.

0

My new Galaxy S9+ worked great for the first two months then I also was unable to record video...still pictures only. I went into applications - permissions - microphone permissions - and turned ON and OFF microphone permissions on various apps. Luckily, I quickly found an app that had microphone permission ON and when I turned it OFF I was once again able to record video. Hope this helps.

0

I was having the same issue, the issue was with Sd card I think. I open the settings>device maintenance>storage>sd card> options at the upper right end> unmount the sd card. After unmounting I waited a minute, then mount the sd card. I opened the camera app and start recording. This solves the problem for me.

1
  • Are you sure the problem is "solved"? Disk problems are transitory, and easily masked. If I didn't know for sure (no "I think" about it), I would only feel confident of the card if it was re-formatted for use, and then only with constant/paranoid review that any written files are fine, including immediate viewing where possible.
    – wbogacz
    Oct 27, 2019 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .