I had a post on https://android.stackexchange.com/questions/14999/how-can-i-restore-the-default-os-on-phone-that-has-custom-build however this got closed because it was a possible duplicate. Unfortunately the duplicate did not answer my question so I am posting again with further details.

Basically I had built the Android source and flashed this to my phone and now I would like to go back to the stock version.

The link in the duplicate points to the following recovery file http://android.clients.google.com/packages/ota/google_crespo/f182cf141e6a.signed-soju-ota-102588.f182cf14.zip

I renamed this to update.zip, and reboot into recovery. I then get a triangle with an exclamation mark. Then I hit the power and volume up key again and see more options, so I then selected 'apply update from /sdcard'.

I receive the error:

 E:failed to verify whole-file signature 
 E:signature verification failed 
 Installation aborted 

How can I restore my phone with stock Gingerbread?

  • Explaining why your case is different is perfect :). I didn't see your comment on the other question -- feel free to flag a question and fill in your reasoning if you think a question should be re-opened to make sure we see it. – Matthew Read Oct 26 '11 at 17:21
  • Thanks! I wasn't sure how to do this (I'm new to android.stackexchange so I may not have enough privileges yet to do this!) – lost_bits1110 Oct 26 '11 at 17:24
  • Oops, I didn't realize you needed 15 rep for that. I'll have to remember to comment on new users' questions so they can @Matt in their comments. – Matthew Read Oct 26 '11 at 17:29

It's an official update, so the signature should be perfectly valid. There are a couple things to check:

  • Thank-you, I have the GT-i9020T, I tried your first link, ie GTi9020t however I still receive the same error :( I believe my bootloader is unlocked, when I go into the bootloader it says: Lock State - Unlocked. I do not have access to the File Manager to check that it is in /sdcard/, however when I plug in my phone to my PC, I dump the file in the first folder that appears, presumably this is the root of the /sdcard/. – lost_bits1110 Oct 26 '11 at 18:17
  • @lost_bits1110 That might be the external SD card (/mnt/sdcard/external_sd/) rather than the internal SD storage (/mnt/sdcard/). Samsung devices are weird like that. Both drives should be mounted to your PC though, so try the other one? I'm really surprised you don't have a Files app or anything (is that an AOSP thing?) but you should be able to side-load one, e.g. AndExplorer. – Matthew Read Oct 26 '11 at 18:24
  • Yes it looks like its an AOSP thing, I wasn't able to find any kind of File Manager type app on here. Also I don't have the Marketplace nor can I connect to a network, so I won't be able to get AndExplorer unfortunately :( – lost_bits1110 Oct 26 '11 at 18:29
  • Okay - when I connect my phone to my PC and run my Android app, I can open up the DDMS view in Eclipse, and I see the File Explorer. In here I see a folder /mnt/sdcard, and my update zip file is here (though I do not see a /mnt/sdcard/external_sd folder) – lost_bits1110 Oct 26 '11 at 18:38
  • @lost_bits1110 Hmm. In that case you could try using the fastboot update command via the Android SDK. It's supposed to ignore signatures if you want to risk it. – Matthew Read Oct 26 '11 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.