1

I have installed Cyanogenmod (v13) on a Xiaomi Redmi 2 phone. So, it all worked, but then I tried a manual update. I booted into recovery (TWRP), and flashed the new cyanogenmod ZIP file; then flashed the gapps ZIP file. But when I rebooted, I found two problems:

  • the device won't finish booting (gets stuck)
  • recovery mode is gone. If I try to boot into recovery, the Mi logo stays there forever

So, I could get into fastboot mode. Then I tried using the fastboot tool from a Linux PC.

The device responds properly:

# fastboot devices 
78768331    fastboot

# fastboot getvar version
version: 0.5
finished. total time: 0.003s

# fastboot oem unlock
...
OKAY [  0.003s]
finished. total time: 0.003s

# fastboot erase recovery
erasing 'recovery'...
OKAY [  0.041s]
finished. total time: 0.041s

But, when I try to flash a recovery image, it gets stuck:

# fastboot flash recovery cm-13.0-20160705-NIGHTLY-wt88047-recovery.img 
target reported max download size of 268435456 bytes
sending 'recovery' (11136 KB)...

I have tried this from two computers:

  • from a notebook, when I plug the device it is correctly recognized as a USB 2.0 device (syslog says it's a EHCI device), but no data is transferred. After some time, the kernel reports that "task fastboot blocked for more than 120 seconds" and prints a stacktrace to syslog.

  • from a desktop computer (also Linux), the device is only recognized as OHCI (USB 1.0), and no data is transferred. But in this case, unlike the notebook, when it tries to transfer, the keyboard stops functioning (OHCI, I suppose).

I also tried a Windows flashing program for Xiaomi devices, which I ran on Virtualbox, but it didn't recognize my phone.

What else can I try?

3

Fastboot is so unpredictable, ouch. Try the following steps.

  • Check if your cable is the stock one. If not, at least make sure it supports file transfer in fastboot mode.
  • Check that USB drivers are installed properly
  • Try to rename the recovery file to just "recovery.img", I know it looks stupid, but it did the trick for me.

Finally, * the device won't finish booting (gets stuck) * recovery mode is gone. If I try to boot into recovery, the Mi logo stays there forever yeah, obviously it doesn't boot, you erased the recovery partition.

Also, I think for fastboot flashing isn't really needed to erase the partition you are going to flash.

  • Thank you! It was the cable, and that's why the phone wasn't recognized as a USB 2.0 device. I could flash the recovery partition now, although it still won't boot (neither into the system nor into recovery) -- but that's a different question. – Jay Jul 7 '16 at 12:32
0

I deleted the old img files( that were used for flashing earlier) from adb and fastboot folder abd the error was rectified automatically…

  • The answer is completely irrelevant bro :) – Gokul NC Aug 21 '17 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.