I have a Xiaomi Redmi 2 phone on which I installed Cyanogenmod. So, after upgrading manually, the phone won't boot anymore (neither into recovery nor into the system). Only fastboot works. (Probably because whatever was in the recovery partition was lost).

So, I can get into fastboot mode, and the phone reacts correctly:

# fastboot devices 
78768331    fastboot

# fastboot getvar version
version: 0.5
finished. total time: 0.003s

# fastboot oem unlock
OKAY [  0.003s]
finished. total time: 0.003s

# fastboot erase recovery
erasing 'recovery'...
OKAY [  0.041s]
finished. total time: 0.041s

Then I tried flashing a new TWRP recovery, that I just downloaded:

# fastboot flash recovery twrp-3.0.2-0-aries.img
target reported max download size of 268435456 bytes
sending 'recovery' (11136 KB)...
OKAY [  0.353s]
writing 'recovery'...
OKAY [  0.290s]
finished. total time: 0.642s

TWRP was the recovery I had installed before.

I also tried flashing the stock recovery, but it still won't boot. What else can I try?

edit: I can boot a recovery image using fastboot boot recovery.img.

  • 1
    Have you tried flashing a stock recovery?
    – asloss
    Commented Jul 7, 2016 at 13:05
  • Couldn't find the stock recovery. It's a Redmi 2... Looks like Xiaomi doesn't make ROMs available. I'll keep searching
    – Jay
    Commented Jul 7, 2016 at 16:46
  • Ok -- I tried flashing the stock recovery, and it still didn't work.
    – Jay
    Commented Jul 7, 2016 at 17:40

2 Answers 2


So, I got it working again. The method was to not flash using fastboot. I actually booted the recovery remotely with

fastboot boot recovery.img

Then flashed cyanogenmod (the system) and gapps from the external SD card. On reboot, the system updated itself and it's working again.

And I can boot into cyanogen recovery mode (but not TWRP, as before).

Seems that it's fixed! :-)

  • 1
    Just saying, what happens if you flash TWRP after this? Also, accept this (your own) answer for sweet reputation :)
    – Andy Yan
    Commented Sep 1, 2016 at 23:22
  • I did not try flashing TWRP again (afraid it's going to get stuck again)...
    – Jay
    Commented Nov 20, 2016 at 10:22

Can you access the phone using ADB while the phone is in recovery?

Also is it possible to set it back to stock rom?

That would be the first thing I would do and go from there

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .