So... How do I disable time traveling?

I have Cyanogenmod 13 on a Redmi 2 Pro (a snapshot version), with opengapps 6.0-pico-20160704. I recently noticed that, when I get from 2016-oct-15 on the calendar to the next day (for example, by choosing "day" view and scrolling to the right), it goes back to 01-jan-1970 (Unix zero time). In month view, if I click on any day of that week, it also goes back in time.

It's funny: I can schedule events on a date within that week, but the calendar won't display them (that weeks stays empty). This happens with two different calendar frontends (Etar and AOSP Calendar), so it must be related to the internal Android Calendar.

Is this a known bug? What should I update in order to try to fix it?

And what will happen if I don't fix the bug before that week? Do I go back to the 70's?


I'm having the same issue and I saw another post saying that it's happening due to the beginning of summer time in Brasil, in October 16, so if you change your timezone it should stop... Obviously won't work for me because I live here and changing the timezone is not an option, but it's worth giving a try :) (even because the person that figured it out didn't say a thing about fixing it). Cheers!

|improve this answer|||||

Change your time zone for one that have actually the same old time you had. For instant, I live in Brazil GNT Brasília - 3:00. I'd faced the same bug at 2016-oct-16 due to the beginning of summer time in Brasil. To figure out just changed to Uruguay timezone

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.