1

My contacts have their phone number in the international format. It needs to be this way, otheriwse I can't call them from another country. As an example

+64 21 1234567

But the incoming calls have the local number, so the software can not correlate them with the contacts. That is, I can't tell who is calling. Example

021 1234567

Points to note (all phone models are Samsung)

  1. On my previous phone, S6, things worked just fine as they did on S4 before that.
  2. Now that I have migrated to S7, I have the above problem (with the same contacts that were migrated across).
  3. My wife had this issue with her S5 and I managed to fix with some setting.
  4. My wife migrated to Note 5 and all still works fine for her.
  5. I have gone through all the settings I can think of, several times but have not found any that will fix this.
  6. I can fix it by adding the local number to the contact as well the international format. WIth several hundred contacts, this is a lot of work and will still give problems when I am outside the country.
  7. The SMS system works fine, its just the voice calls.
  8. I am still with the same provider.

Where is the setting to fix this ?

2
  • 1
    Exactly that's working on all devices I've seen (still have to see the S7). Phone number identification usually bases on the last N digits only (with N ~ 8 AFAIK), exactly for these reasons. I'm not aware of any related setting, or where one might "adjust N".
    – Izzy
    Jul 8, 2016 at 6:41
  • 1
    As far as I know there is no settings for that on your side. The Caller-ID comes from your provider and you cannot change its format. Jul 8, 2016 at 14:24

0

You must log in to answer this question.

Browse other questions tagged .