2

I recently bought a new android phone (Moto g4 plus). Coming from the iPhone, I was eager to root it and take advantage of all the features.

The problem is that whenever I try to flash a recovery image, I get this error:

C:\Users\myuser\adb>fastboot flash recovery recovery.img
target reported max download size of 536870912 bytes
sending 'recovery' (12496 KB)...
OKAY [  0.400s]
writing 'recovery'...
(bootloader) Image not signed or corrupt

OKAY [  0.197s]
finished. total time: 0.601s

Keep in mind that the bootloader IS unlocked, I even get the warning when restarting the phone. Also this does not happen with just one image file. Every single image file gets this error. I have tried many different versions of TWRP, CLW, etc and all of them get this same error. Does anyone know how to solve this?

2

Yeah, I had the same error. The US XT1644 variant can't use the boot.img for the XT1643 and below. I was able to root by installing SuperSU. Run this command:

fastboot boot twrp-3.0.2-0-athene.img

Make sure you copy the SuperSU zip file in the /sdcard/TWRP folder on your device. Then when twrp loads, you can just pick the zip file and install.

protected by Community Dec 11 '16 at 14:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.