I have an LG Optimus V with CyanogenMod 7.1. I cannot install/upgrade anything from the Market. I keep getting "Package File Invalid". I think it may have something to do with s2e, though I only have apps and download cache moved to SD-ext.

I tried to install an app from the Market, and it gave me "Package File Invalid". I then ran adb pull downloadfile.apk to get the downloaded apk. Running adb install downloadfile.apk gave me:


How can I fix this, so I can install apps?

EDIT: Could this be due to not having enough space for my new apps' dalvik cache? I tried to use s2e to copy the dalvik cache to sd-ext, but it's not working. It says "reboot required", and after I reboot, it still says that; I don't think it copied the files at all.

  • Can you install any file off the market or are you getting the same error no matter which file you try and download?
    – jaamgans
    Commented Nov 2, 2011 at 11:14
  • It's weird. When I try to upgrade an app, I get "Package file invalid". When I try to install a new app (one I've never installed before), sometimes it works, and sometimes I get "Package file invalid".
    – gen_Eric
    Commented Nov 2, 2011 at 13:21
  • I updated my market to 3.3.11, and it seems I can install/update some apps now, some still give "Package file invalid". I was able to fix some updates by uninstalling then reinstalling. Why do some apps not install, but others do?
    – gen_Eric
    Commented Nov 2, 2011 at 15:10

1 Answer 1


When I rooted my G1 and was using Cyanogen and we had a similar error we didn't need to reflash the rom, but just the gapps package - try reflashing that. Or other wise on AndroidPolice they have the latest market apk file which you could download and trash flashing that and seeing if that will install over the current market.

If that still doesn't work consider reflashing the ROM and GAPPS package again, but make sure you wipe before flashing. I always found that doing a wipe before each flash made for far fewer issues and errors.

Case in point is my wife is using my G1 running Cyanogen's 2.2 version of Android and has been up and running for the last 6 months and we haven't had any crashes or errors yet on it, and I made sure to do a wipe and clean install when loading it.

  • Updating the market to 3.3.11 kinda helped. Some packages installed/updated correctly, but others still didn't. I can try to reflash GApps (and then re-update my market).
    – gen_Eric
    Commented Nov 3, 2011 at 13:56
  • Thanks for the suggestion, but reflashing gapps didn't help =(
    – gen_Eric
    Commented Nov 3, 2011 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .