I recently installed CyanogenMod 7.1 on my Samsung Galaxy S i9000 and I have some problems now to get ADB on my Windows 7 64-bit computer to recognize the device.

Currently, adb devices returns no entry for my phone and the Device Manager shows a device called "Galaxy S" but with a yellow exclamation mark because a driver is missing.

I've tried to install Samsung Kies as well as the Google USB driver for Windows Revision 4 and point the device manager at the directories with those drivers. It doesn't find anything it can use there.

Which drivers do I actually need for the phone now that it is running CyanogenMod 7.1? And where do I get those and how can I install them?

3 Answers 3


Use the drivers that come with the android SDK. The samsung drivers do not work once CyanogenMod is installed.

  • That's one of the drivers I tried, if I point the driver installation dialog to the folder with the Google driver it just says that it didn't find any driver for the device.
    – user916
    Commented Oct 27, 2011 at 13:52
  • 1
    make sure you have android_winusb.inf in the folder, there should also be androidwinusb64.cat and an amd64 folder. If you have those, it should find the driver. That is the driver I use for my Galaxy S w/ CM7 on both my work and home PCs both run Win7 64bit Commented Oct 27, 2011 at 14:10
  • Thanks, the Google driver is the correct one, I just pointed Windows to the wrong folder, the driver installation fails when I choose the amd64 or i386 subfolders, it has to be the parent folder.
    – user916
    Commented Oct 27, 2011 at 14:32
  • You can also just right-click on android_winusb.inf and/or oem6.inf and choose Install rather than going through the messy detecting/browsing for files/etc process. Commented Oct 27, 2011 at 14:49
  • i always got an error when I tried to "install" the android usb driver inf file. Commented Oct 27, 2011 at 18:51

For anyone else who struggled with not detecting their phone. Here's what happend to me: First I was trying to uninstall the automatic portable device that windows adds when I plug in my galaxy s3. That was silly seems if you manually install the driver it will pick up. I had to go to right click my computer -> Manage -> Device Manager - > Action -> Add Legacy Hardware -> Choose Android Phone -> Browse to ..\AppData\Local\Android\android-sdk\extras\google\usb_driver and select android_winusb.inf -> Then I selected the "Android Composite ADB Interface" option


Ok, the above solution wasn't working any more after a reboot of my pc. So this time I saw my phone was under "Other Devices" in Device Manager. Clicked Update driver, choose from my pc, "Have disk..." and forced it to use the above mentioned composite driver despite the warning and then it worked again.


If you found your device on devices->other devices as android then what you need to do is install the driver for your device. Even if it is cyanogen moded samsung phone, in most cases installing samsung driver will fix the issue.. You can get samsung drivers on the following link:

Android USB Driver for Windows | SAMSUNG Developers

I'm using samsung galaxy s duos with cyanogen moded cosmic ROM. It worked fine for me.

  • I have a Samsung Galaxy Grand Prime DUOS G531H/DS and those drivers worked for me. I can now see the device using adb devices. Thanks! Commented Sep 9, 2016 at 18:56

You must log in to answer this question.