1

On my Galaxy S5 (SM-G900F, Android 4.4.2) I made a nandroid backup of "everything" (boot, cache, recovery, system, etc.) about six weeks ago (using PhilzTouch recovery). Yesterday I tried to restore it, and it seemed to work but when Android had booted up I started getting force closes all over the place.

I tried wiping cache and data, but it didn't make any difference. I had a look at the log for one app when it crashed, and it was due to

java.io.IOException: open failed: EACCES (Permission denied)

I have not changed anything on the SD card since I did the backup (sent the phone in to repair a dead pixel but they wouldn't do it on warranty, so I got the phone back the way it was).

One idea I had was that something was messed up with the file permissions, so I tried Fix permissions but that didn't help either.

I then thought I'd try to flash Lollipop using FlashFire. Everything went well, and I was really surprised to see that now all the apps were working flawlessly! So to get back to KitKat (which is what I want), I then tried flashing the KitKat ROM (BTW, these are all official samsung ROMs from SamMobile. Now it didn't even boot properly, it got stuck on "Android is upgrading - Starting apps...". Tried wiping data/cache again but nothing worked.

I have since tried repeating the but without flashing Lollipop (i.e. flashing the same ROM as the one in the nandroid backup, directly from the restored nandroid backup state), but it always gets stuck on the "Android is upgrading" screen.

So it seems that I CAN restore the KitKat nandroid backup, but it's unusable "as is" because of most the apps force closing. However, if I flash Lollipop "on top" of the backup, everything works.

Can someone explain this, and possibly provide a solution? I'd really like to have this phone exactly as it was when I did the nandroid backup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.