0

I have Sony Xperia M2 (D2303), and i have had Link2sd for quite some time. A while back I created a partition in Minitool and mounted it as ext4 in Link2sd. Sometimes it crashed, but usually waiting or restarting would help, because all it needed was to link lib, obb and dex files. However couple days ago i set up Sleep as Android, and before i woke up a family member took the phone for a while (Facebook, Candycrush - which heat up the phone a lot). So when i woke up and tried to shut down the alarm i couldn't, Sleep app kept crashing. After that I rebooted the phone, only to find out i have 10 installed apps showing, apps showing crash messages, even if i didn't have them in the background. On top of all there is an alarm icon below the clock which i can't turn off because Sleep app is not showing in app drawer.

After 2 days I figured i might flash SuperSu again from twrp, because it wouldn't update binaries. Tried turning Link2sd into a system app to mount ext4, it only shows some grey screen for a second, nothing changes. In settings there is Sdcard present with similar space i had before(1 GB more space- probably just app data wiped) In Link2sd there is Sdcard, as well as the second partition which is showing as unmounted In DiskInfo app i see partition by its name and allocated size(mmcblk1p2) I see Sdcard in computer when plugging in usb. However, I don't see it in Minitool, Disk Management or when running cmd - "diskpart" - "list disk" commands SDHC card is Kingston 32 GB class 10. Total commander app allows exploring Sdcard which is not appearing in Minitool. Not only is partition missing but Sd card as well.

Thank you.

0

I dont use Sony Xperia M2 but I had similar problem with Link2SD after upgrade to Android version 6.0.1 on my Samsung NOTE4 N910C. The reason is - from my point of view - fact, that Link2sd is not longer supported especially for new versions of Android. I used Apps2SD: All in One Tool[ROOT] (cost aprox 3,5 USD in my Country). Link -> Look here

Sorry it is in Polish language but of course You can switch to Your language. This app is still under develop and has more features than Link2SD like working properly recreation of mounting script

  • I have seen some thread on xda about Android M functionality. I missed to write that i had kitkat 4.4.4 yesterday which i now updated to lollipop, because i thought i messed up the kernel as every time I put in sd card and tried to connect to pc, device would restart. Is there any way to regain the lost partition to try with Apps2sd seeing as it is not even visible in partition managers such as Minitool. I thought that memory controller was fried, but then it appeared in Minitool for a while, and even in Diskpart, when i tried running chkdsk phone restarted. Could this be a malware problem? – Ikarus Jul 10 '16 at 12:26
  • Under Linux - there is no problem. Try to use sourceforge.net/projects/ext2fsd that is EXT2 filesys driver for Windows. You will be able to read content of EXT2,3 and 4 filesys under Windows. – mackowiakp Jul 10 '16 at 15:55
  • I tried it shows C and 500mb system partition. Same as MiniTool. I cleaned the sd card contacts, i blew inside the slot. I can see my files in Windows explorer and phone explorer albeit it loads slower than before. 2 days ago everything appeared in MiniTool and then was gone. Could the problem be because i took a 32 GB SD card(29 GB effective) and made a 5 GB partition out of it. Is it too much? Did i damage it. Also now that i updated to lollipop unintended(because of Sony PC companion) could the ART run time make things worse as i had barely 900 Mb left out of a 5gb partition. – Ikarus Jul 11 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.