1

I'm unable to access files on an Moto G3 updated for Marshmallow 6.0 ("this folder is empty" when connected to a pc, tried on several computers). I tried several fixes and guides but nothing out there seems to work.

  1. https://productforums.google.com/forum/#!topic/nexus/6pbWH1yvPMs

Swiped down after connecting to pc, there are no notifications nor options to choose from.

  1. SD card not showing files when connected to pc

Been there, did that. Rebooted, waited... once again, no files & no notification to change USB connection mode. I did the wipe cache partition part too and waited for some good 10 minutes after doing it before connecting USB

  1. I wanted to try more options via USB debugging & such, but I cannot enable that either. I tap a bunch of times on top of the "build number" option in the menu and nothing at all happens: http://wccftech.com/enable-developer-options-in-android-6-marshmallow/

  2. I went on to search how to root the device which seems to require USB debug mode which I could not enable on 3.

I'm not sure if I'm missing something obvious here but none of the answers/guides I tried so far seem to work. Anyone knows what's going on?

0

The Moto G 2015 has known issues with this, and there is a fix most of the time...

  1. Disconnect the USB cable
  2. Navigate to Settings - Apps
  3. Press the Overflow Menu (3 dots in upper right), and select Show system
  4. Find External Storage and Media Storage
  5. Open each item and select Storage
  6. In this screen for each app, press Clear Data
  7. Reboot
  8. After the system appears up and working, wait a minimum of 5 minutes after the phone is fully booted. Databases are being rebuilt for these applications, if you have large SD card with lots of media files (several thousand or more) this may take longer to complete but there is no way to monitor it and know when it's done.
  9. Reconnect the USB cable
  10. Pull down the Notification Panel
  11. Select USB Connection and change it to MTP. Note there may NOT be an icon in the status bar.

MTP connections use the External Storage app, and by association the Media Storage app, for USB access to the device. There is no direct access or "mass storage mode" anymore, it is all software emulated.

If this fails, a full factory reset is usually required. In rare instances, this does not fix it most models have firmware available on XDA, but that step likely is beyond the scope of this question.

Of course, all this depends on a working USB port on the phone and a good cable... although it is extremely, it is possible for the USB port in the phone to be defective.

  • I tried that already to no avail, there's no "usb connection" notification when I pull down the notification panel. Thanks for the reply though, I will continue to search/wait for more suggestions before factory reset. – YuriW Jul 13 '16 at 1:08
  • @YuriW I assume you have tried different cables and usb ports or computers? – acejavelin Jul 13 '16 at 1:28
  • Yes, three cables and two computers + 1 laptop in fact. – YuriW Jul 14 '16 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.