I'm using a rooted Huawei G7 and i'm trying to install BusyBox, but I keep getting an error. I'm 100% sure this error is because there is some weird write protection on /system. I know this because every time I try to change it to RW in ES File Explorer it changes back to RO when I close the app.

I also tried some terminal commands but with no luck so far.

EDIT: Here is the full log:

u0_a161@hwG7-L01:/ $ su
root@hwG7-L01:/ # mount
/dev/block/bootdevice/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0
root@hwG7-L01:/ # mount -o rw,remount /system
mount: Read-only file system
255|root@hwG7-L01:/ # mount
/dev/block/bootdevice/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0

EDIT: When I try the mount command, I always get the error Read-only file system. I don't know why, but could it be possible to put /system in RW mode from the recovery menu?

  • Welcome to Android.SE! We hope you'll like the place and decide to stay. On a stock Android device, /system is normally mounted as "read-only". This makes it more difficult for evil crackers and rogue apps to do Bad Things. If you want to install BusyBox to /system/xbin — as you probably should — you will need to temporarily remount it as "read-write" first. Commented Jul 13, 2016 at 13:47
  • First of all: Is your device rooted? Please edit your question and tell us. Once you have done so, please flag this comment of mine as "obsolete", if you can do so. Commented Jul 13, 2016 at 13:47
  • Yes my device is rooted, i have tried to remount it as rw in es file explorer and i tried several terminal commands like su mount -o rw,remount /system cd /system chmod -R -i * Commented Jul 13, 2016 at 14:43
  • Please type these four commands — su ; mount ; mount -o rw,remount /system ; mount — and look carefully at the output. Each mount command will produce a couple dozen lines of output. One of these lines will probably start with /dev, contain /system somewhere in it, and end with a digit, a space, and another digit. Please edit your question, add a heading labeled "EDIT:", and provide us with the relevant line of output from each mount command. Each time you edit your question, it will be bumped to the top of the homepage, which is good. Commented Jul 13, 2016 at 15:28
  • I edited the thread with a full log. I hope you can make sense of it. If not then feel free to ask for any other information Commented Jul 13, 2016 at 16:30


You must log in to answer this question.

Browse other questions tagged .