Background

SleepBot is a freeware sleep-tracking app. It includes a "smart alarm" feature which claims to help prevent early-morning grogginess and sleep inertia.

There are other competing free apps, but they aren't great. There's also Sleep as Android, which is a very good app; but it's trialware, and it costs US$4 to remove the restrictions after the trial ends.

The problem

Various individuals, such as this one and this one, complain of problems with SleepBot's alarm functionality when using Android 6.x "Marshmallow". They tend to complain about problems regarding SleepBot's smart alarms never ringing at all, or about problems with the alarms' snooze function.

My questions

I don't own any Android 6.x device. But I wonder:

  • Does Android 6.x "Marshmallow" truly cause problems with SleepBot?

  • Are any of these problems due to "Doze" mode?

  • Is there any workaround for any of these problems?


Possibly related: "Alarm clocks aren't working on Android 6".

You should be able to turn off App Optimization. Go to settings -> apps -> click the gear at the top right -> then click Battery Optimization. Add the app to "Not Optimized."

  • Hi and welcome to Android.SE! We hope you'll like the place and decide to stay. Thank you for your answer! Unfortunately, I don't own any Android 6 device on which to test this answer. Do you? If so, might you be willing to please install SleepBot and test your answer? – unforgettableid Jul 15 '16 at 11:48
  • 1
    I can confirm that above does work. My sleepbot app stopped working as soon as I upgraded to the Marshmallow OS. I made this change Monday night July 25. Since then my alarm has been going off as normal when it detected movement after my alarm sleep window. Before it went off right at my alarm. – user178903 Jul 28 '16 at 12:41

I wanted to add this as a comment to the accepted answer but I didn't have enough reputation.

I am using a Galaxy Note 5 and have upgraded to Android 6.0.1 "Marshmallow". I am experiencing the same problem. I have since:

  • uninstalled and reinstalled SleepBot on Marshmallow.
  • added SleepBot as a "Disabled" app in App Optimisation.

These are my observations:

  • My movement-tracking graphs show nothing but a flat line (before I upgraded, the graphs were very dynamic).
  • Smart alarms or normal alarms will not fire within the smart window or on the instructed time respectively. Only when I hit the "Home" key to turn on the screen, the alarm will fire.
  • They will, eventually, go off without waking up the phone by hitting the "Home" key. For example, the smart window is 6:45 - 7:15, the alarm went off at 7:27.

It may be noteworthy that all my testing has been while the device is in flight mode (because I keep my phone under my pillow and don't want the radios on while it is near my head for 7ish hours :) ).

  • My question has a low voting score, perhaps because I don't even own any device running Marshmallow. I wonder if you could please post a new question asking for advice on what else to try? ❧ While composing your new question, you may freely copy and edit from my question and your answer. Even if you copy and edit from my words, you don't have to give me credit. But please do provide me with a link to your new question. – unforgettableid Aug 22 '16 at 16:01

I've experienced similar problems on my Samsung Galaxy S7 running Android 7.0 where the SleepBot alarm hasn't gone off in the morning. I don't use it in smart alarm mode, for the record. When I've picked my phone up and activated it (after thoroughly oversleeping - thanks so much) the alarm has gone off immediately. The problem has been intermittent, and I haven't really noticed a pattern. I'll often keep my phone under my pillow, but also sometimes next to me or on the nightstand. I haven't noticed if there's a correlation between the phone's location and whether or not the alarm has gone off as expected. I've restarted the phone more than once in the time I've experienced these issues.

I looked at the phone's sound settings today, and I have a theory that I've been causing the problem. At the end of the sound settings there's an Easy mute option, which when activated will mute incoming calls and alarms by putting your hand over the screen or turning the phone face down. I have certainly left my phone upside down some nights, although I don't imagine I've slept with my hand on top of the screen. Either way I turned the feature off, so here's hoping that'll fix it.

I have also noticed this, on a galaxy S6 running android 7. However, I have additionally linked it to the fact if the phone is plugged/charging it never occurs. If the phone is running on battery, then it occurs nearly 100%, exactly as user214423 describes. I am going to attempt to disable the App Power Monitor settings, i.e. add it to the exclude list. This didn't happen when the phone was new, it is definitely an issue with either later versions of SleepBot or later versions of Android.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.