1

First of all, thanks for taking the time to read this. I know it's a long post, I'm just trying to be as detailed as possible.

I've a Moto G XT-1032 that stopped working a couple days ago. It has the original battery, original software. USB debugging mode wasn't enabled. It didn't came with an original charger, so I have been using a Samsung Galaxy Tab one. The phone is almost two years old.

This is how it all started: It had low battery. When I got home it connected itself to the wi fi, and tons of whatsapp messages came at the same time. It went off. I thought maybe it had drained the battery. Plugged it in to charge, didn't get the led on, and the battery showed 0% for an instant. Then the phone turned itself on, got the M logo and then the screen went black (like... some sort of backlight is on, but the screen is just black) I turn it off, and it goes back on. No battery image, straight to the M logo, and then black screen. I tried holding power + vol down keys for more than 120 secs, finger pain is the only I got. It can access fastboot mode, but doesn't matter which option I pick, normal powerup, recovery, factory... I select them and then press vol up, but it just goes to the white screen with the M logo, then black screen.

When I plug the charger, and go to fastboot mode, it doesn't show battery charging. Just says battery low (or battery ok). When I plug it to the computer via the usb cable, and access fastboot, it shows battery charging (and it went from low to OK, so it actually charges). The computer doesn't detect the device at all. First time I plugged it, it tried to install drivers, but failed. I downloaded them from motorola's page. If I open motorola device manager, it tells me there aren't updates for my phone... So... I guess it's recognizing it? But I still can't see it. Windows only shows me my C and D drives, but not the phone. Tried different usb cables, different usb ports. Nothing changes.

I sent it to a service, they tested the battery and charging port, they said those were fine. But didn't find the problem.

Any ideas? Suggestions? Thanks in advance!

0

Since you can start the device and able to enter the Fastboot recovery mode, you can easily flash the stock MotoG ROM. That's all you need to do to factory-reset your device (however, if there is data on your device that needs to be backed-up, that's a different story and perhaps deserves a different post:-))

This is the relevant MotoG forum post for your reference. Summarily, you need two things: The stock MotoG ROM to flash to your device and of course, the MotoG drivers (since you say that your PC is able to detect the MotoG, I guess you already have the drivers installed).

As mentioned in that forum, just download and extract the stock ROM and run the flashall.bat. Your MotoG phone will be as good as new!

0

It sounds like the OS went corrupt. You said you can access fast boot, can you access recovery mode? If so try performing a factory reset through there. To see your phone in fast boot mode you will need to download fastboot to your computer and while in fastboot run command "fastboot devices". If you get a device id then the stock rom flash method mentioned before will work, but is slightly more involved and I like to use that as a last case scenario.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.