4

Since a couple of days/weeks, I noticed that my widgets aren't updating anymore on my home screens of my Nexus 6 (Android 6.0.1). It's not related to a single widget, it's all of them. I haven't found a single one that updates at the moment. I have several widgets that should update regularly: chats, weather, Google Fit, call logs etc; and none of them is updating.

When I reboot my phone, it updates the widgets one time, and that's that. Afterwards no more updates.

For example, I have the widget for Google Fit on my home screen, and it is still showing the status from a couple of days ago; when I rebooted my phone.

I tried the Android N beta some time ago (I can't remember if the widgets updated then though). But because there were some problems with applications I use daily, I reverted back to my old Android 6.0.1 build. This revert includes a factory reset. So I tried the factory reset solution. But I'm guessing the Android N beta has nothing to do with my problem?

Are there some things I can try? Are there some settings that I could have executed that froze my widgets? Maybe something with battery optimizations or something?

I don't have to mention to you that widgets that aren't updating are very annoying.

As I already mentioned, I'm using a Motorola Nexus 6 with stock Android 6.0.1 on it. I have all the latest version of the Android version for my phone, and have installed all security patches. Including the July security patch from a couple of days ago.

Update: I'm using the stock Android launcher. I don't have any special applications running that should customize my battery behaviour (like Greenify).

  • What Launcher are you using, Google's or a custom one? – DukeSilversJazz Jul 15 '16 at 13:03
  • I'm using the stock Android launcher. No custom one. – ndsmyter Jul 15 '16 at 16:49
  • I found out that the flipboard app widget causes the main trouble on pre installed phones like Samsung. Just delete the flipboard widget if you have one than restart your phone. – user189975 Sep 30 '16 at 7:07
2

This happened to me quite time ago. Make sure you're not using Greenify or some other app to hibernate your apps. If you hibernate those apps then they won't be able to update because they are not running in the background

Clear the cache and the data for the widget apps in the settings and also for the launcher you're using. Set them up again and they will work just fine. Hope this helps !!

  • I tried this solution, because it seems like a good option to try (so +1). But I'm afraid that my widgets are still not updating. – ndsmyter Jul 19 '16 at 7:06
  • Have you tried changing your launcher ? Which one you use ? – rajatpunkstaa Jul 19 '16 at 13:45
  • I have been trying different launchers, and have have noticed that the problem still occured. Then I got in the documentation of the widgets and found the problem. I'll make a new answer for future reference – ndsmyter Jul 28 '16 at 13:27
2

Possible solutions you could try if you have the same problem as me (as mentioned by rajatpunkstaa; I just repeat them to be complete but give a vote up there too):

  • Make sure any battery saving apps are disabled. Or at least aren't interfering with the widgets;
  • Try to clear the data of the launcher. Best is to delete both cache and app data.

But in the end, this didn't work for me. So I got into the Android widget documentation to find out what made the widgets tick. Or in my case, why they didn't tick. So I found out, that one widget can actually block the updating of the other widgets. Not on purpose, but by accident.

So by adding every widget seperately, with a lot of time in between, I could notice that the problem occurred after a while. The time in between was rather important, because if I did it immediately there was no problem. But after a time the widget would probably crash or something (not visible though), and other widgets stopped too.

So the best solution for me was:

  • Remove all widgets;
  • Add about one widget a day (giving the faulty widget time to crash);
  • As soon as you see the widgets misbehaving, you know the culprit widget; probably the one you last added.

Some tips on this solution:

  • Best to take a widget that updates regularly as the first widget. So you have an idea when something goes wrong really soon;
  • For some reason the stock clock widget keeps working, even though the other widgets stopped working. So probably that widget uses a different updating mechanism or something.
2

Here's how I tried a solution on huawei cam L21 based on the answers above, and it worked.

Settings -> apps -> app_of_widget -> battery -> keep running after screen off...

  • This is the solution that worked for me – Jonathan Landrum Aug 22 '18 at 6:36
1

For me solution that worked is going to settings->Device->Battery and turned off Standby intelligent power saving.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.