I have a HTC Desire, with the official Android 2.3.3. My problem is that not all the apps I have installed are showing on the Market, which means that I can't check for updates to them. To pick one example, Dolphin HD. It's missing regardless of whether I move it to SD or phone memory. I can't detect any pattern to explain which ones show and which ones don't.

I've googled a fair bit and most solutions posted involve uninstalling the updates to the market (no longer possible on this version of Android), clearing the cache of the Market app, or clearing the cache of Google Services Framework, but this doesn't fix anything. I've turned the phone off/on, removed the SD card, dismounted/remounted the SD card etc, plus several combinations of the above. I had the problem before applied the 2.3.3 upgrade. On earlier versions, uninstalling updates to the Market seemed to usually do the trick.

Any more suggestions for things to try?

  • Is your phone rooted?
    – Chahk
    Commented Oct 30, 2011 at 13:14
  • No. I uninstalled one of the missing apps - Dolphin HD - and then installed it again. Clearly I've missed an update (at least one!) as it's quite different. During playing around trying to fix this I ended up with no apps in My Apps at all! Uninstalling and reinstalling one made them come back. I'll have to check later whether all the apps in My Apps matches all the apps on my phone.
    – user5506
    Commented Oct 30, 2011 at 16:37

2 Answers 2


Do you have multiple Gmail or Google apps on your domain logins? I found it confusing, because whatever email account I happened to be reading became the current account in the Market.

So some of my apps ended up being assigned to these other accounts until I figured out that I wasn't logged in as expected. I didn't realize it because they were free apps so there wasn't the issue of requiring a registered credit card for these other logins.

  • I have a few accounts. Now that Google+ allows Google Apps accounts I'm going to remove my other accounts and see if that helps.
    – user5506
    Commented Nov 7, 2011 at 22:24

Try this:

  1. Go to Menu -> Settings -> Applications -> Manage applications -> All
  2. Scroll down to Market, tap on it, and then tap on Clear cache button.
  3. Go back to the listing of apps, scroll up to find the "Google Services Framework" app, tap on it and tap on the Clear data button.
  4. Reboot your phone.
  5. Launch the Market app, and accept the license.

Your installed apps should now be properly linked to your account in the Market. If not, simply download or update any app, and everything should be back to normal.

  • Restart of power off then turn on? I followed your suggestion to the letter (and did a restart) but I didn't get prompted to accept the license and now I have even fewer of my installed apps showing in the Market. I've not been prompted to accept a license for a few months now, so I guess a newer version of the Market app has been rolled out.
    – user5506
    Commented Nov 7, 2011 at 22:21

You must log in to answer this question.