2

-Phone model: Samsung Galaxy Note 4

-Rooted.

-USB debuging was active before the problem.

-TWRP is installed. version 3.0.2-0.

-rom is stock android forgot the version.

-I know the encryption key.

It has been a week that Im trying to recover and couldnt do yet.

Here is the summary of the story.

Problem:

I encrypted the phone and due to the lack of performance wanted to take the encryption off (decrypt it). For some reason decryption didnt end even after 15 hours. It was obvious that there was a problem. it was stack on the samsung logo. So I decided to reboot it. It said "Device memory damaged.The data partition has been corrupted. You need to reset your device to factory defaults. "

when I open in recovery mode via TWRP it says Failed to mount '/data' (invalid argument) Unable to recreate /data/media folder. Unable to mount /data/media/TWRP/.twrps

When I tried to wipe only system data it also gives the same error.

What I have found so far?

Most of the methods includes wiping before getting backup. However I know the encryption key and I want to recover my files. Some of the topics also says there is no way to recover this data, but until this day whenever someone said its not recoverable I always found a way to recover. This is linux and I believe there should be a way to recover this data since I have a encryption key. It shouldnt be that hard. My files are inside internal memory.

What I have tried?

I tried to follow this topic on xdadev. To do this I installed ubuntu on virtual machine. After some processes I managed to get a backup of /userdata directory which was located at /mmcblk0p27. However it cant be mounted and it cannot be repaired with e2fsck -f -y command.

So I'm stacked. I dont know how to recover this data. Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.