0

I have a Galaxy S6 G920F phone. I've replaced the stock firmware with a custom ROM - XtreStoLite. Attempts to encrypt the phone using Android's built-in FDE fail with symptoms similar to the ones described in this other question, but none of the solutions suggested there help in my case.

What I've tried:

  • disable Wi-Fi
  • remove the SIM card
  • hold the phone so that the screen switches to landscape mode
  • factory reset, also tried to encrypt right after the first boot after installing the ROM
  • plugged in to both a PC USB port and a wall charger
  • instal every single additional package supplied by the author in the Aroma Addons Package

None of this helped; the phone simply displays a padlock icon on black background for around 3-4 seconds, shuts down, and after 15 seconds boots normally without reporting any errors. The storage is obviously not encrypted.

What is the reason for this behavior? How can I encrypt my phone?

0

I figured it out - the solution is to perform a factory reset on a clean system right after installation. After this, encryption works normally.

  • I'm having the same problem. By "Factory reset on a clean system" do you mean on the native OxygenOS 3? And then install the ROM? Did you do the Factory Reset through recovery, or from system menu once you're in the OS? – Shek Jul 18 '16 at 14:37
  • @Shek This is what worked for me: I installed XtreStoLite, booted into it, then Settings -> Backup and reset -> Factory data reset (at the very bottom). After this the phone goes through the "long boot" stage again (just like the first boot after installing the OS), and afterwards it lets you set everything up (the language, Google accounts, all that). Once all that is done, you can simply go to Settings -> Home screen and security, set a screen unlock password, then hit Encrypt device. The phone should reboot and encrypt itself this time. – user4520 Jul 19 '16 at 10:48
  • Thanks for replying. Just tried that for my onePlus phone with CM13 but no luck :( – Shek Jul 20 '16 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.