4

I recently upgraded from Nexus 5 to Nexus 5x. I used the automatic process to move my data from the old device to the new, and everything went smoothly, except for the dictionary.

I type in Hebrew (I'm Israeli) and I have a custom dictionary of hundreds of Hebrew words that aren't in the built-in dictionary. (That's because Hebrew has a lot of different declensions and connected propositions, so built-in dictionaries never have all the words you might want to type.)

It took me years to amass hundreds of words that I use every day. I noticed that my new Nexus 5x doesn't recognize these words; when I type them, it red-lines them, and when I try to swipe them, it doesn't guess these words.

I figured that the upgrade process didn't really transfer my dictionary, but then I went into Settings -> Language & Input -> Personal dictionary in my new phone, and saw that all my old words were there! But yet, the phone doesn't recognize them when I'm actually typing.

How can I solve this problem?

  • Are you using Google Keyboard? Is the dictionary with your added words the one set to do spell-checking for your device? – owlswipe Jul 22 '16 at 23:00
  • @JohnRamos I am using Google Keyboard. I went into the settings now and couldn't figure out how to check if my dictionary is "the one se to do spell-checking for your device." It's the one that shows up under Personal Dictionary. – Ram Rachum Jul 23 '16 at 8:05
  • If you go into settings, then language and input, is Spell Checker set to Google Spell Checker and are your words in the personal dictionary right below that? – owlswipe Jul 23 '16 at 13:14
  • So I tried to recreate your problem. I added a word to my personal dictionary, with no shortcut, and when I typed it, it got the squiggly red line! Strangely enough, once I added two more non-words to the personal dictionary (accessed via Settings -> Language and Input -> Personal Dictionary) and gave them optional shortcuts, the first word, still without an optional shortcut, was actually added to my dictionary and lost its red line. And any further words I added to the dictionary worked fully, immediately. So try adding two random English words with shortcuts to your pers. dict. – owlswipe Jul 23 '16 at 13:22
0
+100

Add 2 more words to your personal dictionary (accessed through Settings -> Language and Input -> Personal Dictionary) and give them optional shortcuts. This will make Android start using all of the rest of the words in your personal dictionary again.

(Also make sure that Google Spell Checker is the default spell checker, also accessed in Language and Input settings.)

This might sound like strange advice, but it worked for me.

Here's what I did, as I recounted in my comment above: So I tried to recreate your problem. I added a word to my personal dictionary, with no shortcut, and when I typed it, it got the squiggly red line! Strangely enough, once I added two more non-words to the personal dictionary (accessed via Settings -> Language and Input -> Personal Dictionary) and gave them optional shortcuts, the first word, still without an optional shortcut, was actually added to my dictionary and lost its red line. And any further words I added to the dictionary worked fully, immediately. So try adding two random English words with shortcuts to your pers. dict.

  • Em, I actually didn't do this, I tested my problem again to see whether this solution works and suddenly my problem went away. But here, have a few internet points :) – Ram Rachum Jul 26 '16 at 6:16
  • @RamRachum Ok? Well, glad your problem's fixed :D – owlswipe Jul 26 '16 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.