0

On Google, I found a similar problem on Reddit, which describes exactly what I've got right now: https://www.reddit.com/r/cyanogenmod/comments/3xm0mo/mobile_data_not_working_cm13/

The problem is that, even though I do have cellular reception, and everything (WiFi, SMS, calling) works just fine, whenever I turn off WiFi (or walk outside WiFi) it doesn't connect to the internet using a data connection (3G/4G etc).

What I've tried so far (based on that Reddit post's comments)

  • Reboot my phone
  • Toggle Airplane mode on/off
  • Switch preferred network setting to 3G and then back to 4G
  • Enable Data Roaming (even though I'm still in the country this should be active)
  • Going to Settings>Cellular networks>Access Point Names and trying each of the available options
  • Check my remaining MB-credit on my subscription (I still have >100MB remaining) - this is actually irrelevant since I do not have an exclamation point at my reception-icon

The only thing I haven't tried is some kind of reinstall/rollback of my OS. My Cyanogen version is 13.0-ZNH0EAS45F

When I go to my SIM 1 status, I see that "Service status" says "Data: In service", but (even though my WiFi is turned off) the "Mobile network state" is "Disconnected". Can I force my phone to connect to the mobile network somehow?

PS: This problem has existed for about 2 hours now. Before that it worked just fine.

Update: One of these things might have fixed it. I'm not sure. It suddenly started working again, even though between the time of posting and now I did not change anything about my settings at all. I have (after it started working) reverted all changes to my settings, and it still works. I have no idea how this worked, but it works.

-1

Clean Cache/Dalvik, System and Data and flash Your Cyanogenmod 13 ROM again

  • what? I have no idea what half of these words mean in this context. Dalvik? Where is my cache? How do I flash my CM13 ROM? (my phone came preinstalled with Cyanogen OS 12, which got upgraded to 13) – Joeytje50 Jul 18 '16 at 22:21
  • Okay switch off your mobile, then reboot into recovery. Press power+volume down (for some models press power+volume up). Then recovery menu will come. Then clean your cache. Though your cyanogen os is preinstalled, you can't clean system. But you can clean data. After cleaing data your all installed app will be uninstalled, but files on sd card will not be deleted – Sourav Bagchi Jul 19 '16 at 0:38
  • @SouravBagchi Could you edit your answer to add this information? Comments aren't for important explanations, they're just for temporary messages and to ask clarification (like this one). – Dan Hulme Jul 20 '16 at 12:03
  • After this problem appeared again, clearing cache did not do anything at all either. – Joeytje50 Jul 20 '16 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.