0

I recently upgraded to Marshmallow on my LETV-x500/Letv-1s (base on cyanogenmod). Then I flashed GApps 6.0 Micro. But then after my phone rebooted and I had those "Unfortunately, Setup Wizard has stopped" error. I fixed it by giving all permissions and rebooted again. And then this error popped up:

I keep on clicking on "set my phone" and this keeps popping up.

enter image description here

i had set all permissions to the google-play-services and this change nothing.

I used TWRP.

Please help me. Nothing in my phone is working.

0

Do you isntall Gapps just right after flashing the rom? I mean after rom flashing don't reboot your device, and before these are you wipe all of dalvik/art cache, system, cache, data?


Update:

okay I searched further because my LeEco(LeTV) Le 2 X620 had the same issue, but for this until now haven't CM-based Rom, but this issue not depend from it

but there is a Google framework deep inside the rom, thats used the google apps too, but some reason OpenGApps used a diferent one (I don't know which the original, not inportant, the important is these not compatible with each other)

that framework included every OpenGApps package but if the installer find inside the rom not overwritten by the installer, other words OpenGApps not work on LeEco phones right now (most of them not work, explain later)

so I advice to install the core Google apps/services manually, what you can search for it and download there, and install it in this order (sorry my low reputation not authorize to use more than 2 link in post)

  1. Google Account Manager
  2. Google Services Framework
  3. Google Play Services
  4. Google Calendar Sync
  5. Google Contacts Sync
  6. Google Play Store

some of them has many version depends on DPI, Android version, achitecture so choose wisely

if that complete you are able to sign in store and install other apps to make sure everything work well the reboot probably necessary

that's not the best solution, only a workaround but I do my best

I hoped that helped

  • I have tried both (just right after flashing and after an reboot). I also try with wiped all dalvik/art caches, systemcaches, data and with out wipeing. – Jan Ole Pieper Aug 3 '16 at 20:12
  • I updated the original post – svisystem Aug 4 '16 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.