0

I can't turn on emergency mode in Lenovo Power Manager app, it seams broken with my system.

Emergency Mode is like classic phone mode, only calls, SMS, contacts and clock are enabled. It saves energy.

Problem

Whenever I try to activate it, it starts with Preparing data, please wait... and after that it says: Failed to launch the Emergency Power Saving mode. Sorry, but we tried our best

I've test this app on other Lenovo A916 with deferent ROM, it works there. Why is it not working with my ROM? Could someone help me find out why?

screenshot

Logcat

I've made Logcat log, with hope that I will find cause of this problem and maybe fix it, but no luck. Maybe some experienced Android enthusiast will help me find out what causes the problem. Log file is kinda long but by searching prepareEnvirenmentOperation its easier to get entries

Logcat log is here

Device information:

Lenovo A916, Android 4.4.2, system build id A916_S206_141125_baralajbi

  • What device and Android version? What did you try already? Did it work before – and if so, what changes do you remember having done that might have effect here? – Izzy Jul 19 '16 at 20:31
  • Android 4.4.2, I tried to enable it but this is what I get so far? Any idea? – Paul B Jul 19 '16 at 21:07
  • No idea. I was hoping you'd name your device as well – so other users with the same device could help you out. – Izzy Jul 19 '16 at 21:18
  • Improved question, maybe someone will take a look on that log. It bothers me. – Paul B Aug 11 '16 at 16:21
  • 1
    @Izzy problem solved, it was caused by SuperSU, I changed it and now it works. Thanks for help. – Paul B Aug 22 '16 at 15:18
1

Problem solved, problem was caused by SuperSU root manager. After changing SuperSU to KingRoot it works fine. Weird.

I've tried different SuperSU settings, reboots, etc, but non of them seems to solve this issue. I got weirded out after trying this Lenovo app on my Alcatel tablet... it works perfectly fine there, with KingRoot, so I changed SuperSU to KingRoot on my Lenovo device and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.