I rooted my Nexus S and re-installed a stock ROM. I had my contacts on my SIM card before starting to use my Nexus and I never bothered to sync those contacts to Google. After rooting I don't see my contacts anymore (even in the import contacts screen). However when I try to open the messaging app and type something in the "To" list, auto suggest starts suggesting some of the old contacts.

As part of rooting, I deleted all of my data.

How is it possible that message app is able to fetch my old contacts but I am not able to see them?

  • Sounds like the messaging app is reading the SIM whereas the Contacts app is not. You could probably use another app to copy the SIM contacts into the phone contacts. – Matthew Read Oct 31 '11 at 21:21
  • @MatthewRead you are correct. It's the problem with the ROM that i installed. I didn't notice before posting the question, but i was unable to make/receive any calls. So i re-installed a different ROM and everything worked like a charm. – Bajji Nov 3 '11 at 2:51

In the contacts app, press menu, then there should be some sort of option for display - this lets you change which contacts are displayed. At the minute you're probably just displaying your gmail contacts, but you should see the setting in there to display Sim contacts. My advice would be to copy them to gmail, you should find some sort of export/import tool in your contacts app too - just export all contacts from your Sim to a file on your phone, then import that file and select your gmail contact book, that means your contacts will always be available

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.