I recently bought a Meizu m3 note. Everything works fine in the play store (after I put the SIM in), except the downloading on mobile data connection.

I can browse, search apps and request to install. But the download won't start. It's stuck on the "Waiting for network..." message. See screen cap below.

When switching to WiFi, everything works OK.

Screenshot of 'waiting for network'

  • Same issue and same axon 7 phone. Seems to be related to axon 7 nougat. – Ivan Apr 1 '17 at 3:57

I have the axon 7 go to settings then apps then Google play then tap 3 small boxes in top right corner and uninstall update.... This worked out for me

  • Thanks Man, that worked like a charm. Appreciate your help. – Mukesh Kumar Mar 30 '17 at 9:01

It seems that when disabling Data on WLAN only, in the Download app, Google Play's app download started. See screen cap.

Strange that the Download app and Google Play are connected.

Screenshot of Download app settings


I had same issue on my Xiaomi Mi5, reseting preferences and changing setting didn't work. Finally I tried uninstalling updates in Google Play Store app and that worked.

  • Funny how this was posted 5 hours ago, I have the zte axon 7, and this fixed my problem! – andyADD Mar 30 '17 at 3:46

Goto All Apps settings and Force Stop default(preinstalled) download manager app. Cheers!

  • Axon 7 owner too, and this fixed it for me. I've disabled it as well, will see how that works out. – Steven Huang Jul 23 '17 at 10:29
  • Edit: Disabling the download manager app makes Google Play request it to be enabled. Seems the only solution so far is just to force stop it when it glitches up. Disappointing! – Steven Huang Jul 26 '17 at 8:10

just got done troubleshooting with Google via the play store help feature. I was told that i am experiencing an issue with the current nougat 7.0 OS. I know this thread started before nougat was released, but I just started experiencing this. Running nougat on Axon ZTE 7. They're flavor of nougat is MiFavor 4.2. developers are aware and are"working on the issue work phone manufacturers."

  • Try the comment below, I have zte axon 7 too, and that worked for me. – andyADD Mar 30 '17 at 3:48

Uninstalling the google play update worked for me..

This now raises new questions and concerns, but yeah this got the downloads going again for me


Same issues here. ZTE Axon 7 running 7.1.1 with "waiting for network" message when attempting to download anything from the Google Play Store.

Only fix thus far is to "Uninstall Updates" from the Google Play Store application. Be careful to cancel the automatic update of Google Play Store app the next time you open it, or you'll have to repeat the process.

I have found that doing this seems to bugger my Android Auto, and basically removes links to any 3rd party apps (Like Slacker or Pocket Casts) and requires an uninstall & reinstall of those apps for Android Auto to "re-link" them into the app. This seems to be a Google Play Store issue, not an issue that is specific to one particular manufacturer.

  • "Any thoughts Google?" - Android.SE is not affiliated with Google in any way. – Andy Yan Mar 31 '17 at 11:57
  • According to ZTE Support, Google is aware of the issue and is working on it... I haven't seen a fix yet. The latest .APK for Google Play Store that I pulled from APK Mirror still doesn't work (Link to ZTE Support article: zte-iqorsupport.custhelp.com/app/answers/detail/a_id/5177/kw/…) – mrjlturner Apr 10 '17 at 18:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.