1

I just upgraded to CM 13 nightly from yesterday on my Samsung Galaxy S3 but now it shows no SIM card. Here is what I tried:

  1. Clear system cache
  2. Reboot (>20 times)
  3. Verify the SIM card works by switching it to a different phone
  4. Insert a piece of paper on top of the SIM card to improve connectivity

The phone can not call and say "No SIM card - No service."

Also, this phone came from China (Samsung Midas (I939) by China Telecom).

Thanks in advance!

1
+50

Did you downloaded Cyanogenmod for I939? Cyanogenmod for I9300/I9305/I9300I won't work (I had those 3 phones, they all have different modem). If the ROM you've flashed is not for I939, go back to Samsung stock ROM. Otherwise...

Do you have /efs backup? If you do, restore it, should help. If you don't...

Well, I haven't found any flashable modems for I939, so you should go back to stock Samsung ROM (you can try getting it here (if you are in China you may need to use VPN) or just search it, or look for f.e. "I939KEDLK6_I939CTCDLK6_I939KELK6_HOME.tar.md5" file). It's flashable with Odin.

If it doesn't help, try:

If it still doesn't help, you'll need:

  • working /efs backup (nothing bad happens if 2 phones have the same IMEI afaik), then just restore it and you are done OR
  • working nv_data.bin file. Those aren't common in the Internet, you should look for other people with working I939.

If you have nv_data.bin, do as this Polish guide says:

  • go back to Samsung stock ROM
  • root it
  • (flash recovery if it got deleted)
  • install "18060]三星 I939 番茄花园 4.1.2 三网版 5.0" ROM from tomatolei.com
  • download Root Browser or Total Commander
  • (perhaps remount /efs as RW - download Terminal Emulator and run su -> enter -> mount -o rw,remount /efs -> enter) <- guide says nothing about it
  • remove everything in /efs (or better, move it somewhere else)
  • reboot your device
  • (perhaps again remount /efs as RW)
  • edit /efs/factoryapp/factory_mode contents: change "OFF" to "ON"
  • reboot your device again (perhaps again remount /efs as RW)
  • put someone's nv_data.bin in /efs, overwrite existing file if any
  • reboot
  • create /efs backup (for example with "efs professional")
  • go back to Samsung stock ROM
  • root it
  • right now I'm not sure, if you IMEI is not correct, try installing "18060]三星 I939 番茄花园 4.1.2 三网版 5.0" again or Cyanogenmod

After this you should get correct IMEI number, if not then you'll have the same IMEI as someone else.

If nothing helps, go to service. Official Samsung service may refuse to help you, but you may find unofficial one with Z3x tools

  • 1
    Thanks a lot for the answer! I will get back to you after i try all 3 billion of those possible solutions :) – Meinkraft Jul 25 '16 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.