1

I have a Sony xperia M2 D2303 with kitkat 4.4.4 and compilation number 18.3.1.C.1.17. I have rooted using KingRoot v4.9.5. I have checked that system is rooted using tools such as root checker. Now, I am trying to remount /system partition as RW but without succcess.

I have googled and tried several solutions but nothing works for me:

  1. Access to /sys/kernel/security/sony_ric and try to disable sony ric security using:

    echo 0 > enable

problem is that sony_ric folder is empty, there is no "enable" file and I cannot create it as partition is RO (read-only).

  1. Using ES file explorer or other file explorers as root I have tried to remount partition as RW but it fails.

  2. Using ROM Toolbox pro, and then from terminal emulator I have tried some commands but all fail:

1st attempt:

su 
mount -o remount,rw /system

2nd attempt:

su 
system/bin/mount -o remount,rw /system

3rd attempt:

adb shell 
su 
mount -o rw,remount /system
  1. I have tried to install busybox but it fails as well because I cannot write to /system partition.

  2. I have tried the methods explained here but nothing works:

Method A -> Cannot be applied in my case since sys/kernel/security/sony_ric/ is empty, no "enable" file exists.

Method B -> Cannot install busybox since /system partition is read-only and I cannot make it rw using mount, etc...

Method C -> I have not tried install init.d because I do not know if it a trusted method and whether it works in my device... Could someone confirm if it works?

Method D -> Cannot be applied in my case, no "enable" file exists in sys/kernel/security/sony_ric/

So at this point I have no idea what to do... Any help will be highly appreciated.

1

Use a kingroot remover and replace with SuperSU

King Remover V9

USE FORCE REMOVAL INSTEAD OF START

Once you have root with SuperSU you should have more control ! ( Kingroot works with a temp root )

Init.d is just a simple folder to hold network security tweaks ! ... However People use it to implement Before-Boot operations that aren't always to do with network security !

  • Ok, I will try. One question. If some day I decide to unroot the device, will I have problems if I have replaced kingroot by supersu? Also is it safe to replace with supersu? Many thanks for your answer. – user1624552 Jul 22 '16 at 22:26
  • King remover v9 you provided does not work. It conplete 72 steps (100%) and then nothing happens. Kingroot is already there.... – user1624552 Jul 22 '16 at 23:53
  • King root is the most unsafe way to gain root. I'll check king remover again ! – Gadget Guru Jul 23 '16 at 3:10
  • Did you try pressing on the second button Force removal !... You may need to close the app and re open it after accepting root, and then try force removal – Gadget Guru Jul 23 '16 at 3:14
  • Force removal does nothing. I get the same results. It completes the 72 steps correctly (100%) and then nothing happens. SuperSu is not installed automatically and I should install it manually. But when instaling SuperSu it forces me to update binaries so I update it. After that it says that it has been detected other root apps, so I press ok to uninstall it. Finally SuperSu starts installing but it fails. Also king remover v9 has not deleted kingroot, purify apps and icons. They are there and they even work. What is the homepage of king remover v9? I have not found it in google. – user1624552 Jul 23 '16 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.