1

I want to mount-bind an app data folder in /data/data/... to a user subfolder in order to automatically synchronise the contents for backup purposes. As root I use the following command:

mount -o bind data/data/org.blabla.app/database/ /storage/emulated/0/blabla_database

The command seems to work and I can access the files in the mounted folder as long as I am root. However, as soon as I exit root, the files become invisible and the bind-mounted folder is empty.

How can I make the files visible for non-root users so that my sync app can access the files for backup?

  • Just a guess: Are you using SuperSU? If so, please check whether switching off "mount namespaces" helps. For details, see What does “mount namespace separation” in the app SuperSU do? – Izzy Jul 25 '16 at 6:55
  • Thank you Izzy, you are right! Un-checking "mount namespace separation" in the SuperSU preferences makes a difference. But here comes the weird part: When I change back from root to normal user in the remote SSH, which I am using, I can effectively see the bind-mounted files now. But the files remain still invisible in the file manager and even if I open a new Termux shell and cd into the folder. Isn't that weird?? If I change to root (su -) in Termux I can see the files again %-( Any ideas? – Aron Jul 26 '16 at 12:01
  • Unfortunately no more ideas, sorry. Hopefully someone else can pick up from here. – Izzy Jul 26 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.