2

I am trying to install Lost Android and Wheres My Droid but I always get this error on both apps:

enter image description here

I have sufficient free space and have installed other apps so that's not an issue. I am using custom ROM MIUI 4.4.18.

I found this page having similar issue. They suggest manual apk install which works but updating the apk results to the same error on Google play.

1 Answer 1

3

That seems to be a MIUI-specific error. From the Locus Map help (translated by me):

This error occurs with Xiaomi devices, but has nothing to do with Google Play Store. Error -26 is caused by MIUI's package manager and stands for INSTALL_FAILED_SYSTEM_INCOMPATIBLE. Which means: for some unknown reason MIUI thinks the app is incompatible, and refuses to install it.

Solutions:

  • Try to install an older version of MIUI which is compatible with the app and doesn't block the installation.
  • Then disable automatic updates Aktualisierung of MIUI
  • Alternatively just wait until there's a newer, bug-fixed version of MIUI

Also, additional to your find, there's a thread on MIUI forum, which – surprise! – says almost the same. Dated 2014 (ouch).


Funnily, the same error -26 is also reported for the Samsung Galaxy S3 on Sprint. Folks here seem to have been more lucky. One user reports the following procedure as being successful:

Go to Application manager and find Google Play Store, Erase the cache and data. Then go to Accounts and remove the account associated with the google play services. Restart your phone phone and add the account back.


So if the latter doesn't work, I'm afraid you've to check that with MIUI. I wonder if it really takes them 2 years to get it fixed.

PS: What strangely seems to work is opening the downloaded .apk file using a file manager. Though that should just be an interface to the pm install command (which is also used indirectly by adb install) which did not work out when used directly.

5
  • Thanks for this research. The latter didn't work :(
    – IMB
    Commented Jul 26, 2016 at 20:15
  • Sorry to read that – though after your mentioning of MIUI I expected as much. Seems to be a bug in the MIUI package manager we can't do much about unfortunately. Not sure how you've tried the manual APK install, as there are 2 approaches. From the PC: adb install *.apk. Or, after copying the file onto the device, directly at its shell prompt: pm install *.apk. Afraid that will invoke the very same MIUI installer – but there's a little chance at least the latter gets the "native one" (AOSP) to do the job. Worth a try at least – please let me know then.
    – Izzy
    Commented Jul 26, 2016 at 20:43
  • I installed it manually by simply tapping the apk file inside my phone file manager. The installation went well but once I update it via GooglePlay the same error occurs. I tried the pm install *.apk method via terminal app but it gives invalid version error. For now I think I have to install the apk manually (by simply tapping apk file) on every app update in the future.
    – IMB
    Commented Jul 27, 2016 at 10:17
  • Which, basically, should invoke pm install in the background – providing a GUI for results. Strange. But as long as it works – it does work I take it? So maybe I include that with my answer?
    – Izzy
    Commented Jul 27, 2016 at 10:21
  • pm install does not work, it does not install the app at all.
    – IMB
    Commented Jul 27, 2016 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .