1

I've had a BQ Aquaris M4.5 phone with Android 5.1 for months and have never experienced any problems. However, since last week and without having changed anything that I know of (and not having installed an update from WhatsApp), my phone sends the message before I finish writing it on WhatsApp only. I can only write one or two letters before it sends the message, without me pressing the send button. It continues doing this until I close the app and open it again, but it happens dozens of times throughout the day and I have no idea why. I have erased the cache, used cleaning apps to clean the phone, etc., but nothing solves it. I installed yesterday the latest update and the problem seems even more frequent now. I have searched online but I can't find users experiencing the same problem.

I've thought of doing a factory reset for my phone, as I would like to do it anyway for general cleaning. However, if I have a Google backup and another backup on my SD card, will everything be exactly the same when I restore the phone? Will I actually clean it?

Thank you

  • 1
    1.In whatsapp chat settings option Enter is send has a tick box . If it is enabled, it sends message as soon as you send, if disabled , it allows you to enter a new line in message. Maybe, it is enabled and every time you intend to add a line, you hit enter and the message is sent instead? 2. One Question at a time is preferred in this site but doing a Goggle backup and restoring in most cases will NOT bring it back to current state as far as apps/settings go and certainly not all your data. Only way out for that is to root and take a nandroid backup (Press that tag to read more) – beeshyams Jul 29 '16 at 13:03
  • Thanks for your help but no, I don't have the Enter is send option enabled and anyway it's not that problem. I only have time to type one letter or two before the message is sent automatically. The same happens with emojis, I type one emoji and the keyboard is therefore not showing and the message is sent on its own. – Zynk Jul 29 '16 at 13:44
  • wild guess- tried changing the key board? – beeshyams Jul 29 '16 at 13:53
  • Yes, I did, still nothing :( – Zynk Jul 29 '16 at 20:35
  • Funny enough, changing the keyboard while the problem is occurring solves it (until next time it happens). – Zynk Jul 29 '16 at 21:30
0

As @beeshyams suggested, the problem was not WhatsApp but my keyboard (I am using TouchPal). I don't know what exactly was causing the problem, but uninstalling and reinstalling the keyboard solved it completely.

|improve this answer|||||
0

uninstall touchpal app and all other touchpal's keyborads if any on yr mobile app and just try, i have same problem which is now solved in whatsapp after doing above.

|improve this answer|||||
-1

I was experiencing the same problem and finally found the solution!!! Here is what you have to do:

  1. Turn off your phone
  2. remove battery, sim, sd card
  3. put them back
  4. Turn on your phone

It should solve the problem... It worked for me.

|improve this answer|||||
  • Thank you for your help, but this didn't solve my problem. The solution is already posted. – Zynk Aug 23 '16 at 12:17
-1

If you downloaded and installed a key pad from the google play store, just uninstall and its done. You can install any other key pad if the earlier one behaves the way it did or stick to your original key pad. It worked for me. All the best

Conrad, Ghana

|improve this answer|||||
  • 1
    Thank you for your help, but I already gave this as a solution. Cheers – Zynk Aug 23 '16 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.