Just recently I've missed a few text messages via Google Voice because the alert hasn't come through. As soon as I open the app the backed up messages arrive and trigger the alert.

I have background notifications turned on (or at least I think I have - Background data is "enabled")

Any ideas?

2 Answers 2


I'm having the same problem here.

Check running services under Settings --> Applications --> Running services. Is the Google Voice update service stuck on restarting?

If so, you might want to try and remove apps that are running services. In other words, uninstall apps that you aren't using that are causing excessive amounts of services to run and eat up your free memory.

You can also try Al's suggestions.

  • It seems to be running although it only has 9 minutes of up time vs 20 mins of uptime for all the other services.
    – Gus Paul
    Sep 24, 2010 at 19:28

In the Google Voice app settings, turn off/uncheck the following:

Voicemail display - View and play voicemails from the phone call log

Once I did that and made a test call/vm, I received the notification just like I expect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .