Looking for some "heroic measures" advice here.

Some weeks ago, my Galaxy Tab2 10.1 (GT-P5113; Wifi only) suddenly threw itself into a bootloop frenzy that I have so far been unable to recover from. Here are the facts, symptoms, and the measures I've attempted already:

  • running stock ROM 4.2.2; no root
  • there had been no recent update: when the bootlooping began, the tablet had been on all night but suddenly froze when I started to use it and began bootlooping
  • automatic app updates had been disabled, so I don't think any apps had updated recently
  • device reboots all the way into Android, but freezes and reboots within 30 seconds of achieving the Home Screen
  • booting into "safe mode" still results in bootloop
  • changing system variables do not persist between boots (e.g. enabling USB debugging; changing system volume; turning Wifi on/off)
  • entering recovery always includes message "Installing system update... NO COMMAND" with Andi lying down and exclamation mark symbol
  • "wipe data/factory reset" appears successful, but system reboots to previous state (NOT factory reset)
  • "wipe cache partition" terminates in "Error!" message with Andi and exclamation mark then reboots into the loop

I'm able to start into Odin mode and stock Android recovery, but am UNABLE to make any changes to the system in those modes:

  • attempting to flash TWRP or CWMR using ODIN or HEIMDALL appears successful, but upon restarting into recovery the stock Android recovery <3e> is there with the "no command" error
  • using either HEIMDALL or ODIN, trying to flash downloaded stock ROM appears successful for cache.img; SBL1.bin; recovery.img; but fails about halfway into system.img. Same behaviour whether or not PIT repartition is selected. Reboot shows no change.
  • Using Kies: Kies just searches for the devices and typically fails, or takes so long the tablet is already rebooting by the time it briefly connects
  • trying to install the stock ROM from SD card fails (no useful information provided by the system)
  • dabbled a little with creating a bootable SD card, but the tablet just seems to ignore it
  • have tried mounting the internal storage to investigate the disk's health, but not even sure if this is possible? Ubuntu 16.04 is "unable to mount MTP" and Windows 10 Explorer just doesn't show anything there.

I suspect a physical corruption of the internal storage, but with apparently no means to mount the drive, flash the recovery, flash the system, wipe the data and/or cache, I'm pretty much out of ideas. Maybe the internal storage has become "read only" or has corrupt sectors? Is this even possible?

As far as I'm concerned the device is basically bricked, so I'm willing to try any riskier ideas to kick-start this guy back into life...

(Yes, I understand this is an old device. I like the big screen!)

Thanks, Matt

  • About PIT repartition... did you surf the web searching for the appropriate PIT file?
    – Grimoire
    Commented Jul 29, 2016 at 20:15
  • Hi DMS. Yes, I found and used a downloaded PIT file that was identified as the one for my tablet...
    – Matt V
    Commented Aug 3, 2016 at 23:01
  • Huh... bad situation. As last resort, you may want to try the "NAND Erase All", coupled with "PIT Repartition" to repartition with the .pit you found. Then, flash the stock firmware, and let's see what happens.
    – Grimoire
    Commented Aug 4, 2016 at 15:05
  • Yuh, that mirrors what I'm thinking, too. Trying to PIT repartition so far seems to have no effect. The only thing I haven't tried is the NAND erase, since I don't know enough about it and all what reading I have done suggests there are tygers and dragons and other awful beasts there! I'll do a bit more reading and give it a go. Thanks for the suggestions...
    – Matt V
    Commented Aug 5, 2016 at 16:58
  • Yes, the NAND Erase is not to be touched in regular circumstances. It blasts anything on the eMMC.
    – Grimoire
    Commented Aug 5, 2016 at 17:15


You must log in to answer this question.

Browse other questions tagged .