I'm using a two-week old HTC Sensation. A number of times now, I've tried to download apps (this is happening on multiple apps, not just one) and although they download, they never install. I can see the download happening and getting to 100% in the status dropdown, but it never continues on to install. I don't get any error messages; it just never goes any further.

This happens regardless of whether I download the app from the Market on the phone, market.android.com on my computer, or the Amazon app market.

Android version 2.3.3.

Any ideas?

  • How much free space do you have? – Matthew Read Nov 3 '11 at 20:20
  • 5.2 GB free (out of 7.2 total). Should be plenty for a single app... – EmmyS Nov 3 '11 at 21:02
  • That sounds like it's your SD card, how's the internal space? – Matthew Read Nov 3 '11 at 21:56
  • 1
    Sorry, you're right. .96GB internal; still should be plenty for a single app. – EmmyS Nov 3 '11 at 22:25
  • I assume you've tried re-booting your device? Although you're saying that apps from the market aren't installing either. make sure you have the option to allow UNKNOWN apps to be installed ticked in Android Settings > Applications. See if that helps. – Sparx Nov 4 '11 at 3:38

I also had similar problem on HTC Desire and I've made a blog post about its solution in here.

Basically you have to open "Manage Applications", and clear cache of "Market" and "Download Manager"

  • Well, as I said in the original post, I didn't get any error messages, including the "Download Unsuccessful" message you mention in that post. But clearing the cache for the Market and Amazon Marketplace did fix the issue, at least this time. – EmmyS Nov 4 '11 at 14:39
  • Well, that didn't last. I tried to install a second app and am having the same issues again. And this time, clearing the data and cache of Market isn't making a difference. – EmmyS Nov 4 '11 at 15:34
  • 1
    Try clearing of "Download Manager" as well. BTW what is the version of your Market? – roxan Nov 4 '11 at 15:52
  • I'm not sure what that last comment is supposed to mean... I've tried clearing the data and cache of the Market and Download Manager. Still doesn't work. – EmmyS Nov 4 '11 at 15:53
  • 1
    Try installing this latest market, androidpolice.com/2011/11/01/… – roxan Nov 4 '11 at 16:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.