This appears whenever I plug it in:


I have gone through all settings, tried everything. I want the MTP mode to stay on (I have no desire to enable Mass storage). I know how to invoke this window manually from within the settings.

I just want it not to pop up.

Using Lenovo A536, 4.4.4, rooted, stock ROM. Read through the other threads, they never offer a working solution (just bogus solutions). It always seems to derail towards FTP and/or MSD and making up menu items that are absent in my phone. I have sqlite3 installed, if you know the right database and key, tell me and I can fix it.

  • Just found a partial workaround: Installed this app from Play: play.google.com/store/apps/details?id=com.launcher.plugin Then I set the Nova launcher as the app to run upon both power and USB connection. (It somehow didn't help to just add it to USB.) This only helps if the phone is just showing the home screen. If there is something running, it randomly shows said popup, then goes to the home screen. If it decides not to show the popup, it just goes to the home screen as expected. This leads me to believe an app could be made to overcome the popup. – Zdenek Aug 4 '16 at 17:05

This problem can have three reasons: 1- You connect your mobile phone to the computer, in this case, you should on this page, select the option to only charge and look for an option with the theme "Always do the same" and activate it. 2. Your charger has a problem and your mobile phone recognizes it as a computer. Try another charger. 3- If the problem is not solved after doing the above work, your phone probably has a hardware problem

  • There is no "Always do the same". It never is on any of the Android versions I have seen in this particular menu related to connecting the USB cable. – Zdenek Jan 15 at 17:40

There should be a broadcast receiver for the "connecting to PC" broadcast, which this UI receives and launches itself.

If you're 100% sure you won't need to set this again, try using MyAndroidTools (requires root, of course) and disabling this certain broadcast receiver, or disabling the activity of this UI altogether.

Unfortunately, since I don't have the phone in my hands, I won't be able to figure out which receiver/activity to disable, but it should have "USB" or "MTP" in its name, so search that in MyAndroidTools and report back if anything comes up.

  • Thank you for the attempt. I have tried this and that in that MyAndroidTools application. I would seem that although it does show the relevant system app "Settings" listening for DockService, when I touch it, the switch doesn't flip and it stays enabled. The Superuser allowed does appear. There are several other toggles that seem promising, but won't flip no matter what I do. – Zdenek Aug 2 '16 at 18:21
  • Spent an hour trying many promising settings in that app. Some can't be toggled. The part that did toggle didn't do anything obvious; it certainly didn't get rid of the popup. The setting you suggested isn't there. – Zdenek Aug 3 '16 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.