0

For.... Various reasons, I had to remove /system and replace it, I.e. fresh install my ROM. Now, however, I cannot do the build number trick to open developer options, and going through the dev tool menu states "Developer mode not available for you. You did enable it, right?". I doubt it is a kernel issue, since that copes fine, and the ROM is stable. I'm not gonna re-flash again today (Again, for various reasons). So, does anyone know how I can force it open?

Root methods will not work. Due to how the ROM is built, rooting and unrooting is done by flick of a switch... In the developers options.-NOW OUTDATED INFO, SEE EDITS BELOW

Edits

  • Root Works now! I managed to trip it on in SuperSU.
2
  • Have you used exactly the same zips as before? If not, have you cleared cache & dalvik?
    – pzmarzly
    Aug 2, 2016 at 2:48
  • @pzmarzly Exact same Zips - Though it somehow changed the SELinux state to permissive- and I have wiped cache and davlik that much recently, its unhealthy.
    – Dan Brown
    Aug 2, 2016 at 9:12

1 Answer 1

1

Some ROMs move settings around. For example, on Ressurection Remix a lot of options are moved to new entry "Customisation" in Settings. Check your Settings app.

You can also use ADB or Terminal Emulator and run following command (taken from there):

am start -n com.android.settings/.DevelopmentSettings

You can also check your ROM's forum thread to see if anyone else also had problems with enabling Developer Settings.

6
  • The issue is that I installed the exact same copy of the ROM, but bits have gone missing (I also can't use the home button) meaning I can't access the developer options. Tried the code, to no avail.
    – Dan Brown
    Aug 1, 2016 at 23:02
  • ...can't use the home button - did you remove SetupWizard in the ROM package? That leads to a myriad of weird issues like this, a nonfunctional notification drawer and other stuff.
    – Andy Yan
    Aug 2, 2016 at 2:15
  • @AndyYan Now that you mention it, no setup occured when I booted the thing back up. Any way to force it to life, or shall I just factory reset again?
    – Dan Brown
    Aug 2, 2016 at 8:56
  • It's strange for a ROM to not include at least a stub SetupWizard in its package. Check your current /system/app and /system/priv-app for an APK whose name contains SetupWizard. If there is indeed no presence of it, you have to put a compatible one in, set proper permissions and reboot. Flashing GAPPS (contains Google Setup Wizard) is another approach to this, but will introduce a lot of extras.
    – Andy Yan
    Aug 2, 2016 at 9:03
  • Also, if there's no SetupWizard presence currently, even a factory reset would do no good. For further assistance sake, please also tell us the device you have and the ROM you're now on.
    – Andy Yan
    Aug 2, 2016 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .