1

My local brand phone running KitKat is infected.I've tried various removal tools but of no use. Malwarebytes detects it in /system/app/FileExplorer.apk but I am not able to uninstall it.

How can I remove it without root? I've tried factory reset and hard reset.

ROM : xolo_era_SO14_25092015,kernel: 3.10.16 Device : Xolo ERA

  • 1
    if it is in /sys, there is nothing you can do but flash a new ROM, Problem will be in getting a custom ROM or original stock ROM. Please edit your question to include the device model, in the hope some one can help – beeshyams Aug 2 '16 at 14:27
  • 2
    @beeshyams Either OP confused /sys with /system, or you do (or both): /system is where the OS resides, while /sys is a virtual file system (sysfs) created on boot. As for your second comment: OP didn't ask to root the device, but how to remove that Trojan without root. // It might well be a "false positive" by Malwarebytes. Otherwise, if it really is a malware that managed it into the system area, re-flashing the stock ROM would be an option. – Izzy Aug 2 '16 at 16:26
  • 1
    @beeshyams Yeah, I was irritated as well initially :) But still, as OP doesn't want to root, to me it seems re-flashing the stock ROM (of course downloaded from its official source, together with instructions and possible software to flash it) is the only way out that's left – provided it's really a Trojan, and not just a false alert. I've never heard of a malware placing itself into sysfs – which makes me think of either a false alert or a misspelling in the question :) – Izzy Aug 2 '16 at 16:36
  • 1
    I never trust any software that calls itself "anti virus" for a system where no virus exists. Those apps are often causing more trouble than they're solving (incl. false positives and opening new vulnerabilities on the device – just check what permissions they want to become suspicious). No guarantees, but as I wrote before, it might well be such a "false positive". A Google search for ""android.trojan.gc" filexplorer" doesn't yield a single result. For "android.trojan.gc" there is a single result: this page here. Raises at least an eyebrow, right? ;) – Izzy Aug 2 '16 at 22:32
  • 1
    @MuditKapil Izzy is right. Not only is Malwatebytes throwing a false-positive, and its questionable if antivirus apps are worth downloading in the first place. – Dan Brown Aug 3 '16 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.